19

Unhappy with the unreasonably large text on my 1920x1080 external screen connected to a laptop with a 3200x1800 display in Fedora 24, I tried rescaling the external screen by using:

xrandr --output HDMI-2 --scale 2x2 --mode 1920x1080 --fb 7040x2160 --pos 0x0
xrandr --output eDP-1 --scale 1x1 --pos 3840x0

This has the desired effect, but it causes the cursor to flicker when I move the mouse on the laptop screen. The cursor does not flicker when it is on the external screen. Flickering stops when I revert to 1x1 scaling on the external screen:

xrandr --output HDMI-2 --scale 1x1 --mode 1920x1080 --fb 4120x1800 --pos 0x0
xrandr --output eDP-1 --scale 1x1 --pos 1920x0

How can I stop this flickering?

1
  • Possibly related to a bug in the modesetting driver.See here.
    – jadelord
    Jan 31, 2018 at 8:59

3 Answers 3

18

This workaround helped me. What I do now is after performing a xrandr scale, I run an extra command which stops the mouse flicker.

xrandr --output eDP-1 --auto --output HDMI-2 --auto --scale 2x2 --right-of eDP-1  # Simpler oneliner scaling
xrandr --output eDP-1 --scale 0.9999x0.9999  # Stop flicker
4
  • This is also an open issue for xserver.
    – jadelord
    Mar 3, 2019 at 8:42
  • 1
    running xrandr --output eDP-1 --scale 0.9999x0.9999 works but it slows down display reactions. You can see that when watching some fast video on youtube.
    – matt525252
    Apr 12, 2020 at 10:41
  • 1
    I agree. Using Wayland or the Intel driver on X is a better solution as of now.
    – jadelord
    Jun 26, 2020 at 11:42
  • That was immediately and impressively effective. Good job. Nov 15, 2022 at 2:06
11

I had the exact problem after using scaling with xrandr although with a slightly different setup. Strangely, what helped was the first section on https://wiki.archlinux.org/index.php/intel_graphics#Xorg_configuration . Namely,

"However, to take advantage of some driver options, you will need to create a Xorg configuration file similar to the one below:"

/etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
EndSection

That is probably only relevant if you're running on Intel graphics (and not on a dedicated gpu)

7
  • 3
    Worked for me in Ubuntu, however the relevant file to create is /usr/share/X11/xorg.conf.d/20-intel.conf
    – Simon D
    Jul 28, 2018 at 14:28
  • This worked fine for me in ubuntu 18.04 (unity) Sep 29, 2018 at 7:37
  • 1
    Works perfectly, Ubuntu 18.04 LTS by creating said content in /usr/share/X11/xorg.conf.d/20-intel.conf on a Macbook pro. Note that you have to log out and back in again for the change to take effect.
    – Johan
    May 28, 2019 at 19:24
  • /usr/share/X11/xorg.conf.d/20-intel.conf worked on Fedora 31. BTW the file content starts from Section....
    – Lubo Kanev
    Apr 28, 2020 at 9:24
  • Tested and worked for me with Ubuntu 19.10 running on a Dell Precision 7510 with dual Nvidia and Intel graphics when only the Intel graphics is used.
    – Yan Li
    Jun 28, 2020 at 22:54
2

On a MacBook Pro with resolution of 2560x1600 and a Samsung TV with the resolution of 1680x1050 I found the following command useful:

xrandr --output eDP-1 --auto --scale 0.9999x0.9999 --output HDMI-2 --auto --scale 2x2 --right-of eDP-1

I found it via reading arch-linux wiki and the 0.9999x0.9999 scaling solution in answers on this page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .