On OpenSUSE boot up, it waits on below menu for a long time. How can I shorten the wait time?

I tried to modify /etc/config/grub file to change GRUB_TIMEOUT value. But this option doesn't control the wait time of this menu and it's for the next menu when I choose 'Boot from Hard Disk'.

enter image description here

  • 1
    If you've already installed the OS in virtualbox, remove the ISO install disc and it won't go to the menu in your screenshot at all. What you're seeing is it booting into the ISO that you still have inserted into the virtual DVD drive. That is not the installed GRUB menu.
    – n8te
    Apr 14, 2017 at 6:11
  • @n8te Thanks. That's the reason. Could you write it as an answer so that I can accept?
    – aleung
    Apr 14, 2017 at 7:29

2 Answers 2


Your screenshot is showing the boot menu for the installation disc. This is not the actual GRUB menu that was added during the OS installation, which is why your changes to /etc/config/grub had no effect no it.

After installing the OS in virtualbox you need to manually eject the installation ISO from the virtual DVD drive so that it does not boot into it. After ejecting the disc you will no longer boot into the menu shown in your screenshot.


You can set bootloader wait time via YaST2 Boot Loader module. Timeout value can be set in the bootloader option tab. And this option is for the next menu when you choose 'Boot from Hard Disk'.

You got the screen like in your screenshot because you still attached your installation media. And your BIOS set to load the installation media before the hard disk where your OS is installed.

Make sure you eject your installation media or set the BIOS to boot your hard disk directly to skip that screen. If you use VirtualBox, just change the boot order in that VM instance' General setting or release the installation media in Storage setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.