1

A few days ago I decided I wanted to install Antergos on my laptop. I downloaded the latest ISO file and installed it. I installed the nvidia drivers and got it to work. I used the following command:

pacman -S nvidia nvidia-utils nvidia-settings

I plugged in a HDMI cable and it worked great. I was able to detect the display by using:

xrandr

And the command

lspci -v

showed me that the nvidia drivers where installed for my graphics card (gtx1050).

However, when I lock or reboot my computer, the lightdm greeter shows up on my external monitor. This even occurs when I haven't connected an external monitor. I'll get a black screen and even the backlight is turned off. If I switch to the terminal by using

Ctrl + Alt + F1-F6

I'm able to use commands as usual. When I switch back by using

Ctrl + Alt + F7

the greeter won't show up and my internal display is turned off again.

I tried adding the following to the /etc/lightdm/lightdm-gtk-greeter.conf file:

active-monitor=0

without succes.

Does anyone know how I could fix this?

Please let me know if you need more information.

EDIT: changed 'Ctrl +' to 'Ctrl + Alt + '.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.