2

The internal microphone is listed by the Sound tool of Linux Mint Cinnamon but I cannot use it in any way.

enter image description here

Also in pavucontrol:

enter image description here

Chances that the mic itself is faulty are negligible, it's a brand new Asus, and similar issues have been reported lately but without a solution -like here, also here.

I hope I have more luck here.

 ~ $ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0x81410000 irq 315

EDIT

in response to dirkt's comment:

  • alsamixer shows this:

enter image description here

There is a MM to the right but not under PCM (isn't that the mic?).

  • amixer -c0 contents gives this (pastebin)

  • I have tried to use with Skype and then tested with the 'Sound Recorder' tool, which only creates empty files. - Also I have tried aplay /tmp/test-mic.wav & aplay /tmp/test-mic.wav (like here) to no effect.


Edit

in response to dirkt's second comment:

  • the output of cat /proc/asound/card*/codec\#* - here.The laptop only has one audio jack (entry), for headphones, I do not have an external mic to test if that could work for mic too.
  • Have a look at alsamixer if there is anything muted (MM instead of OO) in the path of the mic which shouldn't be. If you can't find anything, please edit question with output of amixer -c0 contents. How did you try to use the mic? – dirkt Apr 13 '17 at 10:52
  • @dirkt - I have updated the question in response to your answer. – user32012 Apr 13 '17 at 16:43
  • You have controls for a "phantom" (internal) mic jack and a capture channel map, but curiously no other controls for capture/mic. Please put the output of cat /proc/asound/card*/codec\#* in a pastebin. Note that if you are using aplay (speaker) or arecord (internal mic) to test, this will use the Pulseaudio compatibility layer, so make sure in pavucontrol you are using the right device (analog instead of digital etc.). pavucontrol will also show a VU meter for the mic (input tab). – dirkt Apr 13 '17 at 17:00
  • @dirkt - I have solved it as indicated in my answer. – user32012 Apr 14 '17 at 21:21
4

(This might be an Asus-X540S-specific issue.)

I have solved it according to this answer: https://askubuntu.com/a/824806/47206

sudo apt-get install alsa-tools-gui

Then launch

hdajackretask

Then:

  • Check 'Show unconnected pins'

  • Check override pin 0x12 to internal mic.

  • Apply and test. Be sure that the mic level is high enough in sound settings (pavucontrol, etc)

  • If it worked, select 'Install boot override'.

enter image description here


UPDATE

In the Ubuntu 18.04-based Linux Mint 19, I had to check override pin 0x13 to internal mic instead of 0x12.

0

Since I do not have enough reputation to comment, I will add this answer for others like myself. While this answer has been given before, what was left out is that there can be multiple internal mics listed in alsamixer and that you have to mess with the volumes to find which one is your actual microphone.

  • in the case in question there were not such multiple internal microphones listed in alsamixer (nor in pavucontrol) – user32012 May 11 '17 at 6:56
  • If there are multiple internal mics listed, while your hardware only has a single mic, you are likely changing the wrong nodes with hdajackretask (or the BIOS already had wrong information). – dirkt May 11 '17 at 7:39
  • @dirkt - the very specific setting involving hdajackretask worked for the Asus X540S laptop, where the internal microphone was listed in the sound setting but was nor recording input level. - In other cases the situation may be different (but then there is a different question): for example (as I tested in one case) when the mic is NOT listed inpavucontrol under Input Devices tab, it may be because under Configuration tab, 'Analog Stereo Output' is selected instead of 'Analog Stereo Duplex'. – user32012 May 11 '17 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy