2

I tried a backup with this line

 tar cvf - --format posix -b 1024 -X /home/user/altro/file.esclude /home/user | openssl aes-256-cbc -salt  -k "pass" | dd bs=40M of=/dev/st0

The total size of my backup is 1TB

The tape is LTO-5 1.5TB(3tb compressed)

After 15-30 minutes give me this error

[mar apr 11 20:40:07 2017] st 9:0:2:0: device_block, handle(0x0009)
[mar apr 11 20:40:07 2017] st 9:0:2:0: [st0] Error e0000 (driver bt 0x0, host bt 0xe).
[mar apr 11 20:40:09 2017] st 9:0:2:0: device_unblock and setting to running, handle(0x0009)
[mar apr 11 20:40:09 2017] st 9:0:2:0: [st0] Error 10000 (driver bt 0x0, host bt 0x1).
[mar apr 11 20:40:09 2017] st 9:0:2:0: [st0] Error on write filemark.
[mar apr 11 20:40:09 2017] st 9:0:2:0: [st0] Error 10000 (driver bt 0x0, host bt 0x1).
[mar apr 11 20:40:09 2017] mpt2sas_cm0: removing handle(0x0009), sas_addr(0x5001438000aa4a64)
[mar apr 11 20:40:09 2017] mpt2sas_cm0: removing : enclosure logical id(0x500605b0080ad4d0), slot(3)
[mar apr 11 20:40:13 2017] scsi 9:0:3:0: Sequential-Access HP       Ultrium 5-SCSI   Z6ED PQ: 0 ANSI: 6
[mar apr 11 20:40:13 2017] scsi 9:0:3:0: SSP: handle(0x0009), sas_addr(0x5001438000aa4a64), phy(3), device_name(0x5001438000aa4a66)
[mar apr 11 20:40:13 2017] scsi 9:0:3:0: SSP: enclosure_logical_id(0x500605b0080ad4d0), slot(3)
[mar apr 11 20:40:13 2017] scsi 9:0:3:0: TLR Enabled
[mar apr 11 20:40:13 2017] st 9:0:3:0: Attached scsi tape st0
[mar apr 11 20:40:13 2017] st 9:0:3:0: st0: try direct i/o: yes (alignment 4 B)

Is something broken with hw or is a tar/dd error?

  • Did you ever find a solution? I'm seeing the same. – Daniel Jun 6 '19 at 18:17
  • Yes and not, the "solution" was..defective hw,in my case the SAS cable, you have to try if possible with other hw(card,cables,etc). – elbarna Jun 8 '19 at 17:43
  • 1
    Heh. Same here. Turned out to be a too-tightly-coiled fibrechannel cable. – Daniel Aug 18 '19 at 20:41
2

I found the "solution" was defective hw,in my case the SAS cable. After cable replacement works fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.