3

I have a relatively fresh debian install on which I changed the hostname in /etc/hostname. It gives me the following message during boot:

[ 7406.882872] systemd[1]: Starting Journal Service...
[ 7406.920156] systemd-journald[2733]: File /run/log/journal/bfd65934be53484d980ccc7304e5fb23/system.journal corrupted or uncleanly shut down, renaming and replacing.
[ 7497.066194] systemd[1]: systemd-journald.service: Start operation timed out. Terminating.
[ 7587.320229] systemd[1]: systemd-journald.service: State 'stop-final-sigterm' timed out. Killing.
[ 7677.573560] systemd[1]: systemd-journald.service: Processes still around after final SIGKILL. Entering failed mode.
[ 7677.586742] systemd[1]: Failed to start Journal Service.
[ 7677.593748] systemd[1]: systemd-journald.service: Unit entered failed state.
[ 7677.601384] systemd[1]: systemd-journald.service: Failed with result 'timeout'.
[ 7677.625405] systemd[1]: systemd-journald.service: Service has no hold-off time, scheduling restart.
[ 7677.635948] systemd[1]: Stopped Journal Service.

It does this over and over again for about two hours before finally settling on this:

[ 7948.405911] systemd[1]: Starting Journal Service...
[ 7948.443473] systemd-journald[2746]: File /run/log/journal/bfd65934be53484d980ccc7304e5fb23/system.journal corrupted or uncleanly shut down, renaming and replacing.
[ 7948.516285] systemd[1]: Started Journal Service.

When I SSH in and run sudo systemctl enable systemd-journald.service, I get the following:

sudo: unable to resolve host [hostname redacted]
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
   instance name specified.

I have very little experience with systemd; what is causing this and how can I fix it to boot normally?

2
  • Did you also changed the entries in /etc/hosts so the new hostname resolves locally? Edit: Also do you have the `libnss-myhostname´ package installed?
    – Bigon
    Apr 17, 2017 at 8:54
  • @Bigon Unfortunately after another reboot the device stopped booting entirely, so we may never know. Apr 17, 2017 at 19:34

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.