1

Background information: Debian Jessie (8.7) LXDE Desktop Environment. ttf-unfonts-core and fonts-unfonts-extra packages installed (so I can view Korean characters).

Right now I can view and type English (US) of course since I setup Debian using English (time zone set to Korea of course). But, I also want to be able to type Korean (English as main language, Korean secondary). I have tried using "Keyboard Layout Handler", but unchecking "Keep system layouts" and adding Korean language does not work. To switch to Korean I tried moving "KR" up in the "Keyboard Layouts" section in "Keyboard Layout Handler". And setting the keyboard shortcut toggle and using that. I still can't type Korean (only English).

How do I type English and Korean (switch between them and set English as main language if possible)? Any help is appreciated! Thanks!

  • 10wontips.blogspot.co.uk/2014/02/… ? lubuntu is lxde. Ok based on Ubuntu so might be slightly differfent – user8779 Apr 11 '17 at 18:35
  • @arochester LXDE on Debian is different from the one on Lubuntu (slightly). I don't have Language Support Settings in the bottom left menu/I can't find it in the menu (bottom left). I don't even have iBus installed. Trying to install im-switch tries to install im-config. I can install imhangul-common. I can't run im-switch in the terminal because I can't install it. TLDR; Lubuntu is different from my Debian LXDE and so the instruction on the website you gave me does not match or work for me. – cppxor2arr Apr 12 '17 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.