1

I have been using kernel 3.16 in my Dell Laptop for a long time with Linux Mint 17 and previous versions and the problem here had never happened until LM18.

Very often I set the lowest possible brightness, for example at night, or while I am flying for many hours. Using values from 0 to 4882 I used to run this command:

# ie: Set lowest possible backlight brightness echo 0 > /sys/class/backlight/intel_backlight/brightnes

I have always used intel_backlight instead of dell_backlight because it gives much more steps.

Well now with kernel 4.4.0-53-generic it actually decreases the brightness but at night it is still very high even at 0 compared to the brightness levels I used to get with the same command. In fact, using a value of 0 with older kernels, the backlight is turned off.

Just for testing, I have booted my laptop with Debian Live kernel 3.16.0-4-amd64 and it works perfectly. That is how I realized that the problem was the kernel.

Does anyone know if with newer kernels > 3.19 this is a well-known and tolerated behavior? Maybe the kernel code for intel_backlight was modified and ended up with this problem...

Some system information:

System:    Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.2) Distro: Linux Mint 18.1 Serena

Machine:   System: Dell product: Inspiron 5520 v: A14 Bios: Dell v: A14 date: 05/13/2013

CPU:       Dual core Intel Core i5-3210M (-HT-MCP-) cache: 3072 KB

Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller 
           Display Server: X.org 1.18.4 driver: intel

$ ls /sys/class/backlight/ dell_backlight intel_backlight

Also I always use the acpi_backlight=vendor kernel parameter and I can confirm that by changing its value, the problem persists.

Thanks for your time, Frk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.