0

I have been trying to add a second OS Ubuntu 16.04.2, actually I have installed Centos 7 as primary os.

I download the ISO file of Ubuntu and load it to USB drive using the DD. I tried to boot from the USB using the grub2 terminal without success.

Now I am trying to load the ISO from my hard drive from my /home/<username>/download/. I tried to add a new entry in the grub2 menu by editing the /etc/grub.d/40_custom:

    menuentry "Ubuntu 16.04.2 ISO" {
        set isofile="/home/usern/Downloads/ubuntu-16.04.2-desktop-amd64.iso"
        loopback loop (hd0,1)$isofile
        linux (loop)/casper/vmlinuz.efi boot=casper iso-scan/filename=$isofile  noprompt noeject
        initrd (loop)/casper/initrd.lz
    }

finally here is the output of fdisk -l:

Disk /dev/sda: 750.2 GB, 750156374016 bytes, 1465149168 sectors

Units = sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 4096 bytes

I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk label type: gpt

 #####    Start End    Size   Type      Name

 1         2048       411647    200M  EFI System      EFI System Partition

 2       411648      2508799      1G  Microsoft basic 

 3      2508800   1465147391  697.5G  Linux LVM   

Can anyone help or guide me on how to install Ubuntu in dual boot?

  • Are you able to boot from the Flash Drive using the bios or boot menu of the system itself? – RolandiXor Apr 9 '17 at 19:41
  • no not able to boot form any wehre – Djalil lounis Apr 9 '17 at 19:47
0

According to your setup, you are using LVM for partition management. Therefore the /home directory is not accessible without unlocking the LVM volume group (VG) and it will not be easy to load the ISO file without this.

It may be possible to load the ISO but it will be complicated. Please try to boot from USB using BIOS startup options (press a system-specific key before the boot loader is loading, sometimes F1 or F12 or Esc to select the boot device - your USB drive!).

  • In my experience installing a second Linux on an LVM system is a great source of trouble, sometimes not possible, depending on the installation system of the second Linux. – Ned64 Apr 9 '17 at 21:12
  • oh OK and what system do recommend ? – Djalil lounis Apr 10 '17 at 6:20
  • Not sure, because I have not managed to do this, either. You would need a Linux variant that can use an existing LVM volume during installation (maybe someone else knows a suitable one?). Sometimes this is possible with a trick (e.g. mount the LV in a shell during install). The easiest would be to re-install CentOS without LVM and leave a partition for a(ny) second OS. However, you may not want to do so because if you wish to keep data and config you would need to backup (at least) /home to an external disk. I will think some more. Please let me know whether you would consider a re-install. – Ned64 Apr 10 '17 at 7:03
  • No way for me to boot from USB or any thing. All that I have tried was not successful .... – Djalil lounis Apr 10 '17 at 8:40
  • Is there a way to delete everything and start over ? – Djalil lounis Apr 10 '17 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.