1

Problem:

I am trying to install Elementary OS Loki onto a Seagate Backup Plus Slim 2TB portable USB HD, I don't think my problem is specific to the OS. The install completes successfully (using the option to erase the entire drive and letting Elementary do what it prefers), however:

  • I am unable to see the drive when set to UEFI, only Legacy
  • When I select the drive from the boot menu I greeted with "No bootable device -- insert boot disk and press any key"

What I have tried:

  1. Trying the install again but following this guide: http://linuxbsdos.com/2013/10/23/how-to-install-ubuntu-13-10-on-an-external-hard-drive/, since the installers for Ubuntu and Elementary are nearly identical. To summarize, it calls for using the partition manager from the installer to create a partition for root (10GB for me), a paritions for swap (2GB for me), and a partition for /home (502GB). I tried this multiple times, no difference other than one attempt where I couldn't start the install because creating the root partition somehow left 33MB of freespace before it despite my best efforts and multiple attempts at that.
  2. Running GParted from my Elementary OS live USB and setting up GPT instead of MSDOS as my partition table. Creating a 10GB partition for root, a 2GB partition for swap, and a 502GB partition for /home. Ran the install again (this time manually selecting my partitions that I created with GParted). No difference.
  3. (Update 1) I tried to follow another guide: https://help.ubuntu.com/community/UEFI. So, I created a new Elementary OS installation USB ensuring that it was UEFI only. I use GParted from that to then create an ESP EFI System Partition using FAT32 and set the boot flag. I also created a swap partition, ext4 partition for root, and an ext4 partition for /home. Installation seemed to go smoothly, but again there was no difference in my outcome.
  4. (Update 2) Using the partitions from my previous attempt (3), I ran the install again ensuring that the EFI partition (/dev/sdb1 in my case) was selected for the boot install (even though the guide from attempt 1 says that you should select the drive for boot install, not the partition).

This is mostly all new territory for me, so I am sure there is some obvious issue that I am just not knowledgeable enough to find in my search.

Log:

  1. (Update 1) Added my latest attempt to the What I've tried: section. I think my future attempts will use Ubuntu itself rather than Elementary OS, just to be more confident in the guides I find (there are next to none for Elementary itself).
  2. (Update 2) Added my latest attempt (and it worked!), going to put the full solution as an answer and accept it.
1

Steps I took to solve:

  1. Created a new Elementary OS installation USB ensuring that it was UEFI only (a setting via Rufus, this was likely not an important step).
  2. Used GParted running from the live installation USB to:
    • Created an ESP EFI System Partition using FAT32 and set the boot flag.
    • Created a swap partition.
    • Created an ext4 partition that I would later mount root on.
    • Created an ext4 partition that I would later mount /home on.
  3. I ran the installer ensuring that the ESP EFI partition was selected for the boot install.

Extra: I also had to change SecureBoot setting to allow ubuntu/grub through; but that was after it would boot immediately after install only, then disappear.

  • What sizes did you chose for the four partitions? – Peter Mortensen Jan 30 '18 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.