1

I'm installing trying to install an extension that requires gtk+ 3.16 but my current version is 3.14 on Debian Jessie 8. The error message that the extension gives me is

gtkbuilder: required gtk+ version 3.16, current version is 3.14

I'm looking through synaptic package manager to see if I can find the package but I'm not having any luck. I did some searching and I found this gnome ftp https://ftp.gnome.org/pub/gnome/sources/gtk+/3.16/

I downloaded the package, decompressed it with sudo tar xf gtk+-3.16.4.tar.xz then I ran ./configure it was running for a while until it hit

Requested 'glib-2.0 >= 2.43.4' but version of GLib is 2.42.1
    Requested 'atk >= 2.15.1' but version of Atk is 2.14.0

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
    and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.

Should I keep installing each dependency one by one until it's done throwing errors at me or is there a way that it can be installed easily without having to install each dependency error. Usually one dependency depends on a bunch of other dependencies and that could be really time consuming. Any tips or suggestions will be highly appreciated.

UPDATE: I'm currently doing the install each dependency route I installed atk 2.15.1 and glib 2.43.4 and it compiled fine with no errors. But when I try to ./configure on gtk+-3.16-4 I get the following error.

*** 'pkg-config --modversion glib-2.0' returned 2.43.4, but GLIB (2.42.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: 
*** GLIB 2.43.4 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

I ran pkg-config --modversion glib-2.0 and the output was 2.43.4 which means I have the correct glib version installed the error message mentions if this occur to set the environment variable of "PKG_CONFIG_PATH to point to the correct configuration files" but I don't know which file it should point to or what is the path to this file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.