0

In am running Chromium 57.0.2987.133 in FreeBSD 12-CURRENT with the Lumina desktop interface, in a Lenovo Ideapad with a Celeron N3050.

I also set in /etc/sysctl.conf as recommended:

 kern.ipc.shm_allow_removed=1

When opening some pages, Chromium takes too long, and is not able to load the page.

Apparently, the slowness manifests itself on pages with Javascript functions. When opening some sites, or using a particular Chrome extensions that use extensively Javascript like SocialFixer, the browser is not able to open the active page.

For instance, I am not able to open either Facebook+SocialFixer (a JavaScript-based browser extension) or the chrome://settings/ page, ending up to having to close the respective tab.

Also when using an extension to block Javascript, the browser appears to work normally.

When using other browsers in the same machine, the same pages open without any problems.

What can be done about it?

2

Based on this page on Ask Ubuntu Very slow Chromium browser, there appears to be a bug in the Javascript accelerator.

I launched Chromium with --disable-gpu option as the page recommends, and was indeed able either to open facebook and the chromiums settings page. However, disabling the "Hardware acceleration" in the advanced options, does not produce any effects when Chromium is reloaded without --disable-gpu.

So, a workaround seems to be loading Chromium in the command line or changing the call in the Lumina desktop interface to:

 /usr/local/bin/lumina-open \
/usr/local/share/applications/chromium-browser.desktop --disable-gpu

Please do take note that for the workaround to work, any chromium thread left behind has to be killed before invoking it with --disable-gpu

However the bug seems to return even with --disable-gpu being used after a short time of using Chromium. Maybe later threads ignore the setting.

Ultimately, this long standing bug turns Chromium unusable for pages using Javascript (under some configurations?).

One alternative is to install and use Firefox, as I am not so fond of using exclusively the other alternatives (Opera and others for FreeBSD).

Whilst in the past FreeBSD had only a Firefox Linux package, nowadays, there is a native Firefox package. I chose to install the localized version as in:

sudo pkg install firefox-i18n

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.