0

While the terminal is updating for a few hours, if I close the lid, The terminal stops its process. This could be very frustrating in the future when I have to carry the laptop while some terminal process/ WPA crack is going on.

I don't think the laptop is broken because it was bought yesterday. I have been working on ubuntu for 2 years now, and this issue has so far never occurred.

[Things I have tried ]

Either of the following ways are not working:

Tweak Tool: Don't suspend when lid is closed

 Terminal : HandleLidSwitch= ignore

  • Try using a more user-friendly distribution such as Ubuntu. Kali is for experts. – Gilles 'SO- stop being evil' Apr 8 '17 at 22:32
  • 1
    That doesn't help at all. – Ajax Stifler Apr 9 '17 at 4:05
  • 2
    @Gilles Despite the question getting murdered by downvotes this follows my rule: It's asking about a problem Kali Linux shouldn't be doing in its normal use. Even if people here don't like Kali Linux its odd to downvote a question that was well written. – jdwolf May 29 '18 at 5:35
0

Edit /etc/systemd/logind.conf and change the HandleLidSwitch= option to ignore, then reboot the system.

You may need to uncomment the option as well.

(just typing the option in the terminal like you did in the second screenshot won't change anything)

| improve this answer | |
  • Yeah I know, I did what you said. But When I restart logind.conf through command line, Screen goes blank and nothing happens.This seems to be a common problem which many people are facing apparently and theres no solution. And yes, Rebooting won't help. The laptop just sleeps on lid off. Help!? – Ajax Stifler Apr 9 '17 at 4:04
  • Hey, Thanks. You solved the problem. The thing was that I forgot to uncomment the thing in Longind.conf! :D ( I have crippling depression ) – Ajax Stifler Apr 9 '17 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.