6

When I open a file into ranger with a GUI application not listed in the rifle.conf file (i.e. using the open_with command), the ranger terminal window gets "suspended" until I close the GUI app.

For this reason, I'd like to have a way to open files with a specific application, but still get the ability to navigate the files in the ranger terminal.

This is the default behaviour when you open the same file with one of the application listed in the rifle.conf file.

Is there any way to achieve the goal?

7

Try open_with with the f or t flag:

open_with [application] [flags] [mode]

Open the selected files with the given application, unless it is omitted, in which case the default application is used. flags change the way the application is executed and are described in their own section in this man page. The mode is a number that specifies which application to use. The list of applications is generated by the external file opener "rifle" and can be displayed when pressing "r" in ranger.

Note that if you specify an application, the mode is ignored.

Flags give you a way to modify the behavior of the spawned process. They are used in the commands :open_with (key "r") and :shell (key "!").

 f   Fork the process.  (Run in background)
 c   Run the current file only, instead of the selection
 r   Run application with root privilege (requires sudo)
 t   Run application in a new terminal window
  • You made my day :D – tigerjack89 Apr 9 '17 at 10:42
  • 2
    How to make this the default behavior for ranger? That is when I try to open a file by pressing RIGHT, it should open it with the f flag. – Inspired_Blue Mar 12 '18 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.