Trying to mount a shared drive at work via an /etc/fstab entry.

I can mount two of the three possible network shares with the following...

//SHAREDDATA02/WORK1    /mnt/work1  cifs        credentials=/etc/nfs_share.credentials,users,rw,uid=me,gid=me,sec=ntlm,noperm   0 0
//SHAREDDATA02/WORK2/USER /mnt/my_network   cifs    credentials=/etc/nfs_share.credentials,users,rw,uid=me,gid=me,sec=ntlm,noperm   0 0

...the third share is on a different (newer) server though and the following entry...

//UOSFSTORE/SHARED/XDRIVE /mnt/xdrive   cifs    credentials=/etc/nfs_share.credentials,users,rw,uid=me,gid=me,sec=ntlm,noperm    0 0

...results in the following error message...

# mount -v /mnt/xdrive
mount.cifs kernel mount options: ip=,unc=\\UOSFSTORE\SHARED,sec=ntlm,noperm,uid=1000,gid=1000,user=cm1nds,prefixpath=XDRIVE,pass=********
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
# dmesg | tail -n1
[257463.335188] CIFS VFS: cifs_mount failed w/return code = -95

I've tried all of the possible sec options to no avail, so its not a difference in the security protocol implemented on the server.

Searching around I can't find anything on what the return code -95 indicates/suggests.

Any help would be very much appreciated.

  • 1
    I got this to work by adding min protocol = LANMAN1 in the global section for the server.
    – anonymous
    Commented Mar 20, 2020 at 20:57

5 Answers 5


I get into the same problem. For me work adding the option vers=2.0


Maybe your client uses the old SMB1 protocol as default and the newer server only permits from SMB2 and on wards.

I had the same error message on my Ubuntu 20.04 TLS (Client) after I updated my Ubuntu 18.04 server to 20.04. I had configured the client to use samba protocol version SMB1.

mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

dmesg gave me a more precise message

CIFS: VFS: Use of the less secure dialect vers=1.0 is not recommended unless required for access to very old servers
CIFS: VFS: cifs_mount failed w/return code = -95

Since you haven't a version set in your configuration I assume your client uses SMB1 as default. Maybe setting the version to SMB2 with vers=2.0 like ceinmart said will fix that.


//UOSFSTORE/SHARED/XDRIVE /mnt/xdrive   cifs    credentials=/etc/nfs_share.credentials,users,rw,uid=me,gid=me,sec=ntlm,noperm,vers=2.0   0 0

I suggest to update your smb client so it uses SMB2 or newer as default.

  • for me the return code was -22, and no hint to the wrong version in dmesg. Nevertheless, adding the vers option worked
    – casiosmu
    Commented Jul 14, 2022 at 9:58

My problem is that I had

// /mnt/hd2 cifs guest,nodfs

Inside of my /etc/fstab, and the underlying samba server (provided by openwrt) did not support nodfs.


Credential file differences between smbclient and mount.cifs

Encountering same problem:

# smbclient -A /path/to/credential.cred //SERVER/SHARE -c ls | tail -n1
            6070936960 blocks of size 1024. 1832196388 blocks available

Everything is fine, but

# mount -vvv -t cifs -o  uid=1000,gid=1000,credentials=path/to/credential.cred //SERVER/SHARE /mnt
mount.cifs kernel mount options: ip=,unc=\\SERVER\SHARE,gid=1000,user= username,pass=******
mount error(13): Permission denied

... I've noticed the space before username! Reviewing my credential:

username = username
password = such1strongPassword

Tried to remove spaces:

# sed -e 's/ //g' -i /path/to/credential.cred

Did the job!!


I don't know if this specify related to your case, but in my case I tried to secure my SAMBA share from WannaCry so I set the option min protocol to SMB2

min protocol = SMB2

But after that I was not able to access my shares from Kodi and simple mount.cifs command didn't help.

So I'm including this in case some else will come across this question via search like I did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .