1

I followed the this installation guide to install MPICH on my machine. I got the following error while configure:

configure: error: Unable to configure with Fortran support because configure could not determine the size of a Fortran INTEGER. Consider setting CROSS_F77_SIZEOF_INTEGER to the length in bytes of a Fortran INTEGER

Here is the full output and config.log file Thanks for any guide o comment.

  • Will you be using MPICH with Fortran? – Kusalananda Apr 7 '17 at 10:51
  • No I use C++ and C – Abolfazl Apr 7 '17 at 10:54
0

Since you won't be using MPICH with Fortran, you might as well disable Fortran support:

$ ./configure --disable-fortran

or

$ ./configure --enable-fortran=none

Don't forget to also add any other options that you originally used, e.g.,

$ ./configure --disable-fortran --prefix=some/directory
  • Any way I still have error in make, make[2]: *** [src/mpltrmem.lo] Error 1, make[1]: *** [all-recursive] Error 1 – Abolfazl Apr 7 '17 at 11:06
  • @Abolfazl According to this email, you may want to add --without-valgrind to the invocation of configure... But it would be easier to install a packaged version for CentOS. I'm not on CentOS, so I don't know where this may be found though. – Kusalananda Apr 7 '17 at 11:17
0

I had the same problem, and I needed Fortran. Compiling with a few different MPI libraries finally led to the clue (thanks, openmpi): I had gcc/gfortran installed in /usr/local, but /usr/local/lib64 and /usr/local/lib where not in the LD_LIBRARY_PATH. The error message for mpich and mvapich2 doesn't make sense, but it went away after setting LD_LIBRARY_PATH.

  • 1
    While that may work, the preferred way is to pass the correct options to configure. – RalfFriedl Aug 20 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.