1

I bought a TP-Link WN823N Wifi Adapter and I installed the rtl8192eu driver. Before I upgraded the wifi was connecting but airmon-ng wasn't. This is what was showing:

root@kali:~# airmon-ng
PHY Interface   Driver      Chipset
null    wlan0       ??????      

I didn't mind since I was able to connect to a wifi network. After I did an apt-get update, then apt-get upgrade, then apt-get dist-upgrade I can no longer connect to a wifi network as the mac address of the wifi adapter keeps changing. Now when I type the command airmon-ng:

root@kali:~# airmon-ng
PHY Interface   Driver      Chipset
phy0 wlan0        rtl81XXX

Although I can now go into monitor mode, I can't connect to a wifi network. I tried macchanger -p wlan0 and ifconfig wlan0 hw ether 18:d6:c7:1d:a8:37 but the mac address keeps changing as soon as the wifi is about to connect. When I try a live persistence boot from a usb with the installed drivers, I can still connect to a wifi network.

2

This is due to the dist-upgrade giving you the new version of NetworkManager. NetworkManager now handles MAC address changes and so is conflicting with whatever else is trying to change it. This may be of some use to you if you want to have a different MAC address associated with the network. You must change your /etc/NetworkManager/NetworkManager.conf file and remove the SSID configuration in /etc/NetworkManager/system-connections once you've updated the config file. Then of course restart network manager

service network-manager restart

You will find that that blog post outlines how to get started. But also read the man page to see what options are available. I had the same problem you were describing and now macchanger is obsolete. I go for the stable option rather than random but up to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.