I am using a Dell Inspiron 7559 laptop to run Linux Mint w/ Cinnamon ver 18.1. I have tried several Kernels including 4.4, 4.7 and 4.10, all of which the issue persists.

The audio out of the stock laptop speakers seems a bit "tinny" sounding. It is especially noticeable when listening to voice recordings. It occurs in the web browser (Firefox) and in other sources. I have narrowed it down to the "front" speakers only. The subwoofer produces good quality audio.

It should be noted that headphones sound great, with none of the above effects.

Things I Have Tried

  • Adjusted PCM in alsamixer to 75 - helped only a little bit.
  • Using this answer, adjusted the equalizer to 'Laptop' setting. This did not have an effect.
  • Changed the Output Profile in sound settings. This revealed that the front speakers are the cause of the distortion.
  • I suspect that this hdajackretask utility would work, but I seem to be unable to get the settings to save across reboots. The LFE speaker pin shows "unconnected"

My suspicion is that this is some sort of audio driver issue, but my knowledge in these (and Linux in general) is slim.

Has anyone had a similar issue? If so, what is a good way to alleviate this issue? Is there a way to change audio drivers to see if that may help?

Edit Having switched to Fedora 26 recently, the issue persists. I have narrowed it down to the subwoofer being disabled or unrecognized. Using the GUI sound options (I believe the same as Linux Mint, pulseaudio) I get no sound from the subwoofer test.

1 Answer 1


Although still not fully fixed (the audio seems a bit off, but could just need a few tweaks), by far the most effective thing I changed was changing the "Output profile" in the sound options to "Analog Surround 4.0 Output." I noticed the "Fade" slider was set all the way to front. Adjusting it to the mid-way point helped the quality a lot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .