1

I'm trying to enable Turbo Boost on my server. I'm using an Intel Xeon E5 2630 v3 which should support Turbo Boost up to 3.2Ghz, according to Intel's product page.

The problem is that the processor isn't overclocking, and uses 2.4 GHz as a max frequency. To test if the OS is the problem (I have tested Linux Mint and Debian), I've put the SSD in my computer with an i7 3770 where the Turbo Boost works perfectly fine.

This is the output of the "cpupower" command:

mint@mint ~ $ cpupower frequency-info
analyzing CPU 0:
  driver: pcc-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  hardware limits: 1.20 GHz - 2.40 GHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1.20 GHz and 2.40 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.20 GHz.
  boost state support:
    Supported: yes
    Active: yes

It seems that Turbo Boost is enabled (of course, it is enabled in the BIOS), but it won't overclock even though underclocking is working to save energy. Normally it should display the Turbo Boost clock rate of 3.2 GHz as the max frequency, but it won't do it.

So what is the next step to try to enable Turbo Boost on an Intel Xeon server? Do I've to enable some kernel modules or use another govenor?

  • Note that Turbo Boost frequencies can only be used if some of the cores are idle. Maximum Turbo Boost can be achieved when only one core is active. As a result, the boosted clock rates cannot be treated as a general "maximum frequency", because if all cores were to run at full boost simultaneously, the CPU would overheat and be damaged. – telcoM Dec 20 '17 at 13:05
2

I'm programming a module to compute Turbo frequencies straight from the PMU counters. Results are the relative frequencies between the minimum and the Turbo ratios. Using same module, I'm providing access to some processor registers to enable/disable the Turbo feature.

CoreFreq is the experimental tool you can try. It's an open-source project available on GitHub. You will have to build the program or install from the Arch Linux aur repository.

CoreFreq

0

I have the same problem with Intel Nuc 6i5SYH with Debian 8 (Jessie). But after installing Linux Mint 18.1 (Serena), I could see turbo boost working. The problem is in the kernel version. I moved from Debian 8 to Linux Mint because the Linux kernel in Debian 8 was too old (Linux kernel 3.16.7). In addition the bluetooh driver provider indicated a minimum requirement of Linux kernel 4.1 for the driver to work properly. With this new kernel that is packaged in Linux Mint 18.1, I got the bluetooth to work. In addition to that, I got the turbo boost to work also.

Now I can run Kodi and compiz smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.