2

I'm using Debian 8 with Openbox which comes with PulseAudio by default. And I cannot find a volume icon which works properly.

I try Volti (the volume becomes very low and sometimes doesn't work), Pavucontrol (doesn't have a volume icon) and try to compile pa-applet (I can't compile then! Many others have the same problem) and volctl (doesn't appear on the panel).

I didn't try volumeicon because in many forums people say that they don't work properly with PulseAudio, so I did not even try then.

I read about pulseaudio-ctl, but it hasn't a volume icon.

Any help?

0

I have tried again to compile the pa-applet (it aren't on Debian repository) and looking in the "issue" of his project on GitHub, I find a fork that a dude made and he fix the problem of compiling that I have. So, case closed. If you are looking for an icon volume, just compile the pa-applet through the original project on GitHub or by this fork that I mentioned. =)

The original project.

https://github.com/fernandotcl/pa-applet

The fork.

https://github.com/Strubbl/pa-applet

  • Thank you very much i am looking to this functional fork for my Devuan Jessie :D – inukaze Feb 2 '18 at 19:53
0

Try pnmixer - this is the perfect little applet for controlling volume in Tint2. Add it to your autostart file in $HOME/.config/openbox.

0

Another simple quick option for volume control using PulseAudio with Tint2 would be to install pavucontrol and add it the the tintrc launcher options by adding launcher_item_app = /usr/share/applications/pavucontrol.desktop example or tintrc:

# Launcher
launcher_padding = 2 5 2
launcher_background_id = 0
launcher_icon_background_id = -1
launcher_icon_size = 20
launcher_icon_asb = 100 0 0
launcher_icon_theme_override = 0
startup_notifications = 0
launcher_tooltip = 0
launcher_item_app = /usr/share/applications/Thunar.desktop
launcher_item_app = /usr/share/applications/org.kde.konsole.desktop
launcher_item_app = /usr/share/applications/firefox.desktop
launcher_item_app = /usr/share/applications/pavucontrol.desktop
  • Thanks fellow! If I'd known that I wouldn't have removed Pavucontrol from my system! – user224753 Apr 8 '17 at 18:12
0

I installed Openbox, and indeed was missing the Volume widget. My machine is Debian Stretch 9.6 at moment of this writing. I installed the Package "volumeicon-alsa" - sudo apt install volumeicon-alsa

  • Open the tint2 config file:

    sudo [text-editor] $HOME/.config/tint2/tint2rc
    

    Re-arrange the panel items display and order in the "#panel" section.
    For ex."panel_items = TSECB"

  • add a new config section for audio as E-'executor':

    # Executor 1  
    execp = new  
    execp_command = volumeicon  
    execp_interval = 0  
    execp_has_icon = 1  
    execp_cache_icon = 0  
    execp_continuous = 0  
    
  • Save the file $HOME/.config/tint2/tint2rc

  • Update the running tint2 with "sudo killall -SIGUSR1 tint2"
  • start tint2conf GUI, and go to "panel items" and add the "Executor" that has been created and apply changes.

You should now have the audio widget showing up.

  • No sudo should be required to edit files in the own home. On the contrary, if the file did not exist before, using sudo will force consequent edits to go through sudo, as well... (This is too small a change to be able to edit.) – Zoltan K. Feb 25 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy