2

I want to compile Nano from source for my friend.

I have successfully compiled it on all of my computers and he's having Linux Mint 18.1 too.

I don't know why; or better said I don't know what is missing in his system for UTF-8 support as per this configuration message:

*** Insufficient UTF-8 support was detected in your curses and/or C
*** libraries.  If you want UTF-8 support, please verify that your slang
*** was built with UTF-8 support or your curses was built with wide
*** character support, and that your C library was built with wide
*** character support.

I tried to install various development packages and it solved several other issues, but this one I am unable to solve since I didn't manage to google much about this issue.

I am quite exhausted, so I temporarily installed the compiled Nano editor with disabled UTF-8 support on his computer.

Any clues appreciated.

0
4

It looks like you need to install libncursesw5-dev and/or libslang2-dev; that’s what’s missing according to the config log.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.