2

I ran pacman -Syu yesterday and seeing quite a few updates, walked away from the computer while it was doing its thing. When I came back the lock screen had come up, and I was surprised to find that I couldn't login despite entering my password. I should have probably tried switching to TTY but I didn't think of it.

I assumed that the problem would be resolved on a reboot and pressed the reset button. Now Manjaro refuses to boot. Specifically:

  • I see the BIOS stuff as usual
  • My drive is encrypted, so GRUB asks me for the passphrase as usual
  • After decrypting, GRUB menu comes up
  • If I choose any of the Manjaro boot options, I see the message from systemd displaying the version, and immediately after the screen starts flashing (looks like it's being turned off and on but the screen is always black)
  • The HDD light also flashes occasionally
  • At this point the computer is unresponsive and won't react to Ctrl+Alt+1-7 for TTY or even Ctrl+Alt+Del. I have to hard reset to get out of it.

I am guessing the problem is bad video drivers. I think if I could somehow boot into Manjaro without launching my DE, Cinnamon, I could then tty to rerun the updates (maybe they had failed at some critical point), look at the logs or just tinker with the video drivers until I can get it to work again. However, currently all I have is the GRUB menu.

  1. Is there something I can type in the GRUB command line (c) that will tell Manjaro to not load any video or GUI stuff?
  2. Is there something I can do in the GRUB editor (e) to make the existing options boot without GUI?
  3. Could I somehow use a liveCD to get into my installed Manjaro system and run commands from there? For instance if I chrooted into my HD would I be able to just run pacman -Syu?

I have seen some recommendations online that suggest editing the GRUB menu and adding various parameters to the linux command, but my GRUB config file is apparently very complicated, and looks nothing like the examples I saw. I'd paste it here, but I'm not sure how to get it out of my computer. Also, I'm really confused about what keys to use in the GRUB editor.

  • I'm no expert, but I'd expect a livecd would be the most reliable as far as both finding the problem and solving it. – Hatchet Apr 5 '17 at 17:03
  • @Hatchet Right now I don't actually have access to a LiveCD (my USB is broken) so if possible I'd like to try any other options first. Also, it's not obvious to me what to actually do from the LiveCD, see #3 in my question. – Bagalaw Apr 5 '17 at 17:04
  • I'm unfortunately not terribly experienced in working with bootloaders/grub, so I'll be of little help there, sorry. (I feel your pain, though!) Do you have more than one kernel installed atm? Trying to boot a different kernel might help. – Hatchet Apr 5 '17 at 17:09
  • This sounds like a GPU driver issue, with X trying to restart on fail repeatedly. Add 3 at the end of GRUB's boot line, then check journalctl -b -1 -p err. Then try mhwd --help for driver options. The Manjaro wiki has a section on this, as well. – Mioriin Apr 5 '17 at 18:20
  • @Mioriin adding 3 to the line starting with linux and ending with splash dropped me in a working TTY. That's exactly what I needed, thank you! Wish I could upvote your comment. – Bagalaw Apr 5 '17 at 23:38
4

I followed Mioriin's suggestion and pressed e at the GRUB prompt to edit the config. Then I found the line starting with linux and ending with splash and added a 3 to the end. Then I pressed F10 to boot.

This brought me to a textual TTY screen where I could enter my username/pass and was able to run CLI commands normally. I ran pacman -Syu, hoping that if I let it update itself successfully the problem would magically go away.

It appears that the python package dateutils was installed, and was causing pacman's update to fail. It seems that pacman tries to do big updates in a single transaction, to avoid partial update state due to interruptions, but despite this I think my system got borked by the update attempt.

I uninstalled dateutils with pip uninstall python-dateutils. Then I ran pacman -Syu again and it completed successfully. I ran pacman -Syyu just to make sure that the update was good, and it reported no out-of-date packages. I then also ran pacaur -Syu in the same fashion. After this I checked dateutils with pip list and it appears to have been installed back by the pacman update.

I rebooted and my computer, including GUI, worked as before.

  • I couldn't update my system, since the networking settings are not configured.How did you solved that issue? – Kevin RED Feb 27 at 11:17
  • @KevinRED Unfortunately I don't recall anymore whether it worked on its own or the first few things I tried got me working internet, but I had an ethernet connection so that might be part of it. In your case I would follow any online guide for networking on arch with CLI, and/or try an ethernet cable if possible. – Bagalaw Mar 18 at 0:01
  • Also you could boot from a livecd which should have working (or easily configurable) networking and chroot into your installed arch. – Bagalaw Mar 18 at 0:02
  • I did with chroot and it's working now. Thanks – Kevin RED Mar 18 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.