3

I am using docker sparsely. I don't need the daemon to be running all the time. I would like to disable it from starting up automatically.

I tried doing :

sudo systemctl disable docker

but it still shows up.

enter image description here

I am running debian 8.

Docker seems to take a long time to close, and so my shutdown times are much longer. I just want to disable the docker daemon from starting automatically on boot

  • 3
    Are you sure it still autostarts after reboot? Cause the command you've used is a correct one. UPDATE: if you expected that docker would stop immediately after running disable - nope. Then you have also to systemctl stop it. – ddnomad Apr 4 '17 at 18:19
  • 1
    The picture I sent is after a boot . And it has the dockerd processes. If I do service dockerd stop then they all go away – harveyslash Apr 4 '17 at 18:20
  • hm, that's weird. Are you sure you don't start it elsewhere? – ddnomad Apr 4 '17 at 18:22
  • 1
    so i just discovered that i was also running nvidia-docker, which was enabled. doing a systemctl disable nvidia-docker fixed the problem – harveyslash Apr 4 '17 at 18:33
  • 1
    glad the issue is solved! – ddnomad Apr 4 '17 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.