1

I was accessing my Android data(files) through Virtualbox(windows), it was very very slow, I forced shutdown, but now my encrypted debian won't start anymore, I'm not a pro, if someone have an idea of what is the source of the problem please send me a message

errorMsg1

errorMsg2

  • .device
2
  • Wow, that's a really dirty screen... time to clean it, I'd say!
    – user
    Apr 4, 2017 at 18:26
  • @Michael Kjörling ahah I agree
    – yeayeayea
    Apr 4, 2017 at 18:29

1 Answer 1

0

On the face of it, this might not be due to the failed shutdown. To attempt continuing without the USB device working:

  1. Edit options for the current boot (e.g. press the shift key at the grub menu to stop the countdown, and follow onscreen instructions); add init=/bin/bash to the line which lists linux kernel options like root=, and then boot the system. Wait for the scrolling to stop. Hit enter, and you should see a bash command prompt ending in #.
  2. mount / -o remount,rw
  3. vi /etc/fstab # vi, text editor of the ancients, which can be assumed to exist
  4. Use j / k keys to scroll up/down to the line containing /mnt/usb-....
  5. i key to enter insert mode
  6. Insert character #, at the start of the line to disable it.
  7. Esc key to return to vi command mode.
  8. :wq to Write changes and Quit.
  9. poweroff -f
1
  • @sourcejedi Thanks a lot, I don't have enough free space to save grrrr, will by a usb key tomorrow to fix this, thanks again !!! @ Michael Kjörling thanks for your help also :)
    – yeayeayea
    Apr 4, 2017 at 19:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .