0

I had earlier got help here fresh linux mint 18.1 install - no wireless, though the live cd it worked fine in but I needed to move from "stable" to "current", in the debian variant Astra Linux common.

I've tried doing the same thing as in the prior post, but things are a little different. I had the kernel 4.8.0-? but then I read on here somewhere to try a jessie-backport kernel. So I added it to the source list and found 4.9.0-0.bpo.2-amd64.

I rebooted and the mouse now works!

So then I moved on to fix the wifi. Already had dkms and wireless-tools. So I downloaded broadcom

~$ sudo aptitude -t jessie-backports search broadcom- 
i   broadcom-sta-dkms          - dkms source for the Broadcom STA Wireless driver                                                                                   
v   broadcom-sta-modules       -                                                                                                     

sudo dpkg -i broadcom-sta-dkms_6.30.223.271-5~bpo8+1_all.deb 

but the install fails because of no headers... so I look for them (in jessie-backports) but there is a failure without any resolution;

sbh@sbh:~/Downloads$ sudo aptitude -t jessie-backports install linux-headers-4.9.0-0.bpo.2-amd64
The following NEW packages will be installed:
  libssl1.0.0{a} linux-compiler-gcc-4.9-x86{ab} linux-headers-4.9.0-0.bpo.2-amd64 linux-headers-4.9.0-0.bpo.2-common{a} linux-kbuild-4.9{a} 
0 packages upgraded, 5 newly installed, 0 to remove and 15 not upgraded.
Need to get 10.3 MB of archives. After unpacking 59.3 MB will be used.
The following packages have unmet dependencies:
 linux-compiler-gcc-4.9-x86 : Depends: gcc-4.9 which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     linux-compiler-gcc-4.9-x86 [Not Installed]         
2)     linux-headers-4.9.0-0.bpo.2-amd64 [Not Installed]  



Accept this solution? [Y/n/q/?] n

*** No more solutions available ***

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     linux-compiler-gcc-4.9-x86 [Not Installed]         
2)     linux-headers-4.9.0-0.bpo.2-amd64 [Not Installed]  
Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

So I think I want to install it.... but I already have gcc-6, gcc-6-base, and I suppose most, if not all, of it.

I did try installing the compiler in the solution as well but it complained of no gcc-4.9. I then tried to install it but it complained it was not available - maybe it is on a wheezy backport (I just thought...)

PS. I just looked on the browser instead of searching on the CL and noticed, https://packages.debian.org/jessie-backports/linux-headers-4.9.0-0.bpo.2-amd64 that there are dependencies for the linux-headers: ...compiler..., ...common...., and ...kbuild... But I see that the compiler depends on gcc-4.9. Still Why won't it compile under gcc-6?

UPDATE

I had already chased about 90% of the dependencies down in packages.debian.org/jessie-backports and installed them via dpkg -i, including the last broadcom-sta-dkms_6.30.223.271-5~bpo8+1_all.deb, in order. But I went ahead with @GADR3 advice and ran the modprobe commands and now it works!

I will try to move out of a bpo kernel, with the assurance of knowing I can select the kernel in the way described in his comments.

Here is my /etc/apt/sources.list:

h@h:~/Downloads$ cat /etc/apt/sources.list
# deb cdrom:[OS Astra Linux 1.11.4 orel - amd64 DVD ]/ orel non-free main contrib  
deb ftp://mirror.yandex.ru/astra/current/orel/repository/ orel non-free contrib main  
# deb-src ftp://mirror.yandex.ru/astra/current/orel/repository/ orel non-free contrib main  
# deb ftp://mirror.yandex.ru/astra/stable/orel/1.11/repository/ orel main contrib non-free  
# deb ftp://mirror.yandex.ru/astra/stable/orel/1.11/repository-update/ orel non-free contrib main 
deb http://ftp.debian.org/debian jessie-backports main
# following from stack exchange GAD3R
deb http://httpredir.debian.org/debian/ jessie main contrib non-free
1

You are using the BCM4360 ( info from your question here)

You don't need to upgrade your kernel version from backports (you have the 4.8 kernel version).

The wifi can be enabled following the steps described on the debian documentation page:

Edit your sources.list and add contrib non-free component :

deb http://httpredir.debian.org/debian/ jessie main contrib non-free

Then run:

apt-get update
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
modprobe wl
  • If this breaks my trackpad/mouse, is there a simple way to revert this? I did a dry-run and I guess could just write it all down and uninstall... Right? (I'd rather have a mouse than wifi :) – nate Apr 3 '17 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.