0

I have managed to lock myself out of linux (ubuntu).

I installed amdgpu-pro, video drivers for graphics card (Radeon RX470) and then followed their guide to add myself to the video group with (as is)

sudo usermod -a -G video $LOGNAME 

Then logged out for it to take effect, now when I login, the screen blinks off and then back to login screen. I tried changing password for my username using recovery mode logging in as root, but to no effect.

The guide I was following AMDGPU-PRO installation instructions

  • 1
    It likely doesn't have to do with your password, but with the video driver. You might try going to a console (Ctrl-Alt-F2), logging in, and undoing what you did (either adding the user to group video, or installing the video driver in the first place). This may well let you log in again, though you won't have the video configured. – Tom Hunt Apr 3 '17 at 17:54
  • Yes, I could login and uninstall amdgpu-pro through console, only then I was able to login again through login screen. Removing user from the video group with 'gpasswd' didn't have any effect. Another thing, I had installed amdgpu-pro but didn't power the GPU, after installing/uninstalling a couple of times, I powered it up, then faced the screen freezes, but that was set straight by disabling processor graphics from BIOS. I am now able to login and using GPU with amdgpu-pro with integrated graphics disabled. – port Apr 3 '17 at 19:09
  • 1
    Cool. If you solved the problem on your own, you can write in an answer to your own question and accept it. This lets future searchers get hints if it's the kind of solution that might be useful for others. – Tom Hunt Apr 3 '17 at 23:18
3

I had this same problem a few moments ago. I solved it by logging in recovery mode an then remounting partition to be writable (I was getting some errors because of the "Read-only" mode):

mount -o rw,remount /

And then in your installation folder:

./amdgpu-pro-install --px

After that reboot your system and the problem should be gone

sudo reboot
  • I don't remember the exact process that solved the problem then, but I did remount partition to writable and then installed with --px. But I don't remember if these had any effect. A/B testing is a difficult, when you are okay as soon as problem is solved. – port May 13 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.