2

Because I eventually need to run this on docker I try to create a container with a current version of Chrome 57 x64 on CentOS 7.3. Unfortunately this does not work until I create a very bloated image which contains tons of other packages (nearing 1.500 in total, yum group install "Server with GUI" for example solves my problem). When I try to base my work on the minimal image I simply fail with an illegal instruction message.

I use the script provided by Richard Lloyd but this fails too like trying doing a "manual" install using yum install chrome.rpm.

I know there are containers provided on docker hub but unfortunately I am forced to use CentOS and can not use anything based on Debian or Ubuntu or other linux distros.

I followed Jakes advice and ran rpm -ivh chrome.rpm and installed the mentioned dependencies manually:

yum install lsb
yum install GConf2
yum install libXSrcnSaver

But this doesn't make any difference because yum also resolves those dependencies and I still get this error:

traps: chrome[11478] trap invalid opcode ip:7fe4e56fb68b sp:7ffce95deb30 error:0 in chrome[7fe4e2f9c000+6aa5000]

This is the information I get from cat /etc/*release*:

CentOS Linux release 7.3.1611 (Core)

Derived from Red Hat Enterprise Linux 7.3 (Source)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

CentOS Linux release 7.3.1611 (Core)
CentOS Linux release 7.3.1611 (Core)
cpe:/o:centos:centos:7

The rpm was either downloaded by the script mentioned above or by downloading it from https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm.

  • Have you tried this: rpm -ivh chrome.rpm Instead? – Luka Apr 3 '17 at 13:13
  • You saw my comment you should tried it already so we fasten up and resolve your issue. I think this is yum error that is why i asked you that. Please try – Luka Apr 3 '17 at 15:49
  • Is that newest version? From where have you downloaded rpm file? Can you please give me output of cat /etc/*release* – Luka Apr 3 '17 at 15:59
  • I do not know what are your needs, but i recommend you to try 42.0.2311.90 version of chrome, I am sure it will work. – Luka Apr 3 '17 at 16:06
  • Yes, 57 is the latest version and I think 42 is too old to be secure. I will provide the exact version info of CentOS 7.3 x64 when I am back to my computer – Marged Apr 3 '17 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.