I tried installing Debian 8.7 on my Lenovo FLEX laptop. I downloaded the Netinstall from Debian's website and wrote the ISO file to a USB stick.

When I ran through the install process, it gave an error when it came to updating and installing GRUB. I forget the exact wording, but it was an error with update-grub. I continued installing despite the error.

If I try booting into Debian, I get a black screen with this error and command line...

error: unknown filesystem
Entering rescue mode...
grub rescue> _

Here are images of the error, along with my BIOS's security and boot settings.

How do I install and boot Debian correctly with UEFI? (I also do not know much about UEFI vs Legacy booting).

  • To allow the grub installation on gpt disk , you should have a bios-boot partition (size=1M). You can create it manually . Some linux distro will create it automatically. – GAD3R Apr 3 '17 at 8:41
  • Boot-mode is UEFI disable fastboot, in Uefi-menu. And secure boot. – user192526 Apr 3 '17 at 11:22
  • @Bahamut When I disable fastboot and enable secure boot, I get the error debian has been blocked by the current security policy. – Username Apr 3 '17 at 21:27
  • you should not enable secure boot but disable. – user192526 Apr 3 '17 at 21:33
  • @Bahamut Disabled it. Still getting the error and command prompt I described in my question. – Username Apr 3 '17 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.