3

I have a RAID 1 which was managed by Intel Rapid Storage Technology drivers. Im migrating this system to Fedora Linux and I ran mdadm --assemble --scan and it seemed like there was an array available via /dev/md126..I successfully mounted it and accessed the data I needed. But then I wanted to check the health of the array, the BIOS is reporting completely intact.

I ran

[root@localhost ~]# sudo mdadm --detail /dev/md126
/dev/md126:
      Container : /dev/md/imsm0, member 0
     Raid Level : raid1
     Array Size : 1953511424 (1863.01 GiB 2000.40 GB)
  Used Dev Size : 1953511556 (1863.01 GiB 2000.40 GB)
   Raid Devices : 2
  Total Devices : 1

          State : clean, degraded 
 Active Devices : 1
Working Devices : 1
 Failed Devices : 0
  Spare Devices : 0


           UUID : **OMMITTED**
    Number   Major   Minor   RaidDevice State
       -       0        0        0      removed
       0       8        0        1      active sync   /dev/sda

From this output it seems that only 1 device is attached? Also there is a degraded status listed.

sda and sdb should both be members of this array. Here is the output of my status command:

[root@localhost ~]# cat /proc/mdstat
Personalities : [raid1] 
md126 : active raid1 sda[0]
      1953511424 blocks super external:/md127/0 [2/1] [_U]

md127 : inactive sda[0](S)
      3028 blocks super external:imsm

unused devices: <none>

Not sure what md127 is representative of here either. In anycase here is my /etc/mdadm.conf :

# mdadm.conf written out by anaconda
MAILADDR root
AUTO +imsm +1.x -all

How should I configure my existing array properly without corrupting data?

@Miorrin ****************************EDIT ADDED LSBLK -f - ****************************

$ lsblk -f
NAME              FSTYPE     LABEL          UUID                                                      MOUNTPOINT
sdd                                                                                                   
├─sdd2            ntfs                      *OMITTED*                                          
└─sdd1            ntfs       System Reserved
  *OMITTED*                                          
sdb               ddf_raid_m                *OMITTED*
└─ddf1_New_VD                                                                                         
sde                                                                                                   
├─sde2            ntfs                      *OMITTED*                                          /run/media
└─sde1                                                                                                
sdc                                                                                                   
├─sdc2            crypto_LUK                *OMITTED*                      
│ └─luks-*OMITTED*
│   LVM2_membe                *OMITTED*                    
│   ├─fedora-root ext4                      *OMITTED*                      /
│   ├─fedora-swap swap                      *OMITTED*                      [SWAP]
│   └─fedora-home ext4                      *OMITTED*                      /home
└─sdc1            ext4                      *OMITTED*                      /boot
sda               isw_raid_m                                 

The two 1.8T volumes should be in the same raid Thank you all for any assistance!

  • Please add output of lsblk -f. We need to see the base partition layout outside of mdadm to make sense of this. – Mioriin Apr 8 '17 at 23:44
  • @Mioriin Posted as edit – Rice Apr 25 '17 at 21:16
  • That's an 'F', not an 'L' in lsblk -f – Mioriin Apr 25 '17 at 22:13
  • @Mioriin sorry it took me so long to get the edit correct, I was gone from my terminal for a time. Would you be able to still take a look? I omitted the UUIDs – Rice Jun 2 '17 at 4:55
  • I was actually hoping to get the UUIDs with that, so we could see which partitions are tied together in the RAID (they share IDs). Anyway, just backup the data and rebuild the whole array from the ground up, to make sure it won't suddenly die and take the data with it. – Mioriin Jun 2 '17 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.