Xterm and the .xdefaults file were not pre-loaded on my system in the first place and even after running Xterm once, I had to create .xdefaults myself. I believe I've put it in the right place:


For what reason is Xterm ignoring my .xdefaults file? It looks like this now:

xterm*dynamicColors::     true
xterm*background::        black
xterm*foreground::        white
xterm*utf8::              2
xterm*eightBitInput::     true
xterm*saveLines::         32767
xterm*scrollTtyKeypress:: true
xterm*scrollTtyOutput::   false
xterm*scrollBar::         false
xterm*loginShell::        true
xterm*faceName::          Monospace:pixelsize=11
xterm*jumpScroll::        true
xterm*multiScroll::       true
xterm*toolBar::           false
xterm*geometry::          100x30

Is this correct?


1 Answer 1


Two colons (::) isn't correct syntax.

Also, you'll get better results using the class name XTerm than the instance name xterm.

Also, ".xdefaults" isn't right (that's a leading "X" rather than "x", and most configurations insist that you suffix the filename with the hostname, e.g., ".Xdefaults-myhostname").

You didn't mention xrdb - that's commonly suggested as a convenient hammer (aka "solution"). But if you're using ".Xdefaults-whatever", xrdb is largely irrelevant.

To see what's visible in the X resources, I'd install "appres", and do

appres XTerm
  • OK, did that, but XTerm still isn't remembering my settings from last use. How do I make that happen?
    – Jeff Seale
    Apr 1, 2017 at 23:34
  • Wow great, .Xdefaults-hostname did the trick for me on Fedora 30, had been looking some time for a working solution. Aug 3, 2019 at 17:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .