1

I have installed armbian on SD card and I cannot get no network. Neither ethernet, neither wireless. Only thing I managed is to connect to it via serial port. Here is some information about my network im connected to:

Gateway: 192.168.8.1
Dhcp: 192.168.8.1
DNS: 192.168.8.1

Network DNS always assigns addresses from 100-200

root@orangepizero:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         -               255.255.255.0   !     0      -        0 -
192.168.8.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

root@orangepizero:~# cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eth0 inet dhcp
 gateway 192.168.8.1
 netmask 255.255.255.0

auto wlan0
 iface wlan0 inet dhcp
 wpa-ssid *****
 wpa-psk *****

I have tried assigning static addresses, and some other tips I found on the internet, and I had no success. Device is still without connection.

Here is my current ifconfig eth0 (although it has ip that I placed, it is not connected to the router)

eth0      Link encap:Ethernet  HWaddr e6:f5:19:a6:1b:e6
          inet addr:192.168.8.121  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::e4f5:19ff:fea6:1be6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:237 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:10602 (10.3 KiB)
          Interrupt:114
  • What dhcp client are you using? dhcpcd or isc-dhcp-client ? – gripen fighter Apr 16 at 3:06
0

Your route is wrong. It should look something like this:

 Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
 0.0.0.0         192.168.8.1     255.255.255.0   UG    600    0      0   eth0

Check your DHCP settings. The gateway and netmask settings are ignored when using the dhcp setting.

  • No success there. Here is my current route: Destination Gateway Genmask Flags Metric Ref Use Iface default 192.168.8.1 255.255.255.0 UG 600 0 0 eth0 192.168.8.1 * 255.255.255.255 UH 0 0 0 eth0 – Marko Apr 2 '17 at 16:21
  • Ok, now the default route looks ok, but you have changed the second route to a host route, which is not necessary. You should have two entries: default 192.168.8.1 255.255.255.0 UG 600 0 0 eth0 192.168.8.0 0.0.0.0 255.255.255.0 U 600 0 0 eth0 – Johan Myréen Apr 2 '17 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.