3

I am using kde, I have virtual box running on one virtual desktop, in seamless mode. This works well except that my kde windows can cover, or be hidden by the task bar of the guest (this bar is at the top). Everything from host and guest avoids the host taskbar at the bottom.

I want the guest taskbar (at the top), and host windows to avoid each other. That is host windows to not use top of screen.

Whatever I do to get the host windows to avoid the top, also causes the guest taskbar to avoid the top.

I have tried a few things:

  • Guest on top (not what I want).
  • Guest on bottom (not what I want).
  • I created a blank panel (for this desktop only and put it at the top of the screen), the problem is that the guest panel avoids this area as well, if I could tell virtual box not to avoid it, then it would work fine.
  • As above, with windows can cover (this would work, if I could list which windows are allowed to cover. E.g. just virtual box).

I though I got it to work once, but this is because it took a while for the guest to realise. When it did the guest started avoiding as well.


using

  • kde: 4.14.2
  • Debian: Jessie
  • Virtualbox: 5.0.36 r114008
  • Guest: Windows 7 (used for backwards compatibility, with some stuff from work colleagues).
1
+25

With a window open, if you click on the control icon in the upper-left corner, click More Actions ->, and click Special Window Settings, you can configure a great number of parameters about a given window's position and behavior, and even have those settings persist.

Some combination of Size & Position -> Position and Size & Position -> Maximum size might do the trick for you. "I don't know how one would say "apply these settings for all windows except this one," however.

(These instructions apply to Plasma 5. KDE 4 is very, very out of date at this point, but the features may be available there in the same place.)

  • I was playing with those, but as you say, even if I can get the setting correct. I would want to apply to all windows (except one), only on specified desktop. (+1 for having a go) – ctrl-alt-delor Apr 11 '17 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.