9

I have a 1TB HDD (/dev/sda1, mount point /run/media/<name>/4733A97E4133EADF) that I'm trying to mount as read-write, but I can only get it to mount as read-only.

System:

$ uname -a
Linux <hostname> 4.10.6-1-ARCH #1 SMP PREEMPT Mon Mar 27 08:28:22 CEST 2017 x86_64 GNU/Linux
$ lsblk -f
NAME   FSTYPE LABEL       UUID                                 MOUNTPOINT
sda                                                            
└─sda1 ntfs               4733A97E4133EADF                     /run/media/<name>/4733A97E4133EADF
sdb                                                            
├─sdb1 swap               d9cea12d-5273-49ef-8950-3cd662fe63c7 [SWAP]
└─sdb2 ext4               e09a8578-53e9-4c26-9a97-a47b6350a1ab /
...

What I've tried

  • Adding a fstab entry to automount the drive on boot:
$ cat /etc/fstab
# 
# /etc/fstab: static file system information
#
# <file system>                 <dir>                   <type>      <options>           <dump>  <pass>
# /dev/sdb2
UUID=e09a8578-53e9-4c26-9a97-a47b6350a1ab   /                       ext4        rw,relatime,data=ordered    0   1

# /dev/sdb1
UUID=d9cea12d-5273-49ef-8950-3cd662fe63c7   none                    swap        defaults            0   0

# /dev/sda1
UUID=4733A97E4133EADF               /run/media/<name>/4733A97E4133EADF  ntfs        defaults,users,user     0   0

I've tried with defaults, defaults,users, and defaults,users,user. Rebooted after each change, but the drive is still mounted as read-only:

$ ls -l /run/media/<name>
...
dr-x------ 1 root  root  4096 Mar 28 17:35 4733A97E4133EADF
...
  • Manually remounting:
$ sudo mount -o remount,rw /dev/sda1 /run/media/<name>/4733A97E4133EADF
mount: cannot remount /dev/sda1 read-write, is write-protected
$ sudo umount /run/media/<name>/4733A97E4133EADF
$ sudo mount -o rw /dev/sda1 /run/media/<name>/4733A97E4133EADF

At this point, the command just hanged for a few minutes, so I terminated it.

$ sudo umount /run/media/<name>/4733A97E4133EADF
$ sudo mount /dev/sda1 /run/media/<name>/4733A97E4133EADF

No change.

As of yet, I have not been able to write to the drive at all (from this system, at least), even as root.

chown, chmod have no effect because the filesystem is read-only.


What must I do to (auto)mount this drive as read-write, with normal (non-root) user access?


Have tried solutions from the following:

  • 2
    The ntfs kernel driver does not support write access, use the ntfs-3g package. – ingopingo Apr 1 '17 at 17:00
8

Although @ingopingo answered the question in one of the comments, i am going to write an answer with further information now.

By default the Linux kernel only supports reading from the NTFS file system. For read/write access you will need a read-write NTFS driver like the ntfs-3g package from extra repository.

After installation with sudo pacman -S ntfs-3g you are able to mount your NTFS partitions the usual way with sudo mount /path/to/ntfs /mount/point. This is possible due to a symlink of /usr/bin/mount.ntfs to /usr/bin/ntfs-3g.

Note: You need to have root privilegs to mount the filesystem. Requirements for an exception are listed in the ntfs-3g-FAQ.

Using the default settings the NTFS-partition will be mounted at boot. Put the following in your /etc/fstab:

/path/to/ntfs /mount/point ntfs-3g defaults 0 0

To be able to read-write with a non-root user, you have to set some additional options (username has to be changed to your username):

/path/to/ntfs /mount/point ntfs-3g uid=username,gid=users,umask=0022 0 0

3

I also had a read only mount problem and already used ntfs-3g. If someone else experiences this, check out ntfsfix /dev/yourPartitionToMount. It comes with the ntfsprogs under arch linux. This fixed my issue. I found it in the arch linux forum

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.