3

I'm running Debian Jessie, with xfce4.

Problem automount game-DVD. USB-Sticks and USB-HD's are mountet as expected. I use udisks2.

lsusb | grep -i media Bus 003 Device 003: ID 0e8d:1806 MediaTek Inc. Samsung SE-208 Slim Portable DVD Writer With a normal Video-DVD udevadm,udiskctl,gvfs-mount

cat .config/xfce4/xfconf/xfce-perchannel-xml/thunar-volman.xml 
<?xml version="1.0" encoding="UTF-8"?>

<channel name="thunar-volman" version="1.0">
  <property name="automount-media" type="empty">
    <property name="enabled" type="bool" value="true"/>
  </property>
  <property name="automount-drives" type="empty">
    <property name="enabled" type="bool" value="true"/>
  </property>
  <property name="autobrowse" type="empty">
    <property name="enabled" type="bool" value="false"/>
  </property>
  <property name="autoopen" type="empty">
    <property name="enabled" type="empty"/>
  </property>
  <property name="autoplay-video-cds" type="empty">
    <property name="enabled" type="bool" value="true"/>
    <property name="command" type="string" value="/usr/bin/mpv -fs --alang=de dvdnav://menu"/>
  </property>
  <property name="autoplay-audio-cds" type="empty">
    <property name="enabled" type="bool" value="true"/>
    <property name="command" type="string" value="/usr/bin/audacious -p cdda://sr0/"/>
  </property>
</channel>

No entry in /etc/fstab. No other packages installt like pmount or something else.

I ran in the same error for about 6 month and could solve it, with installing libblkid from stretch.

What I try to solve it.

  1. install anew lbblkid from stretch higher version since for 6 month

  2. try differnet USB-Cable

  3. control that dbus-launch thunar is in my autostart

  4. Try differnet DVD's

I use the DVD-Device rarely, so I don't know when the Problem came back.

In apt-history I found a Kernel-upgrade and an upgrade for eject.

I found out it is no Kernel-Problem or with systemd. Kernel from oldstable and boot with sysv-init doesn't help.

Edit2 it is not a hardware-problem. Booting Live-session works proper.

3

Got him. Udev was to blame. I downgradet the relevant packages.

Automount and autoplay is now working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy