0

I am using Manjaro with i3 desktop on Virtualbox and I can't seem to figure out what the mod key is (I'm using a standard English keyboard).

  • I've done the expected finger mashing and have tried several different combinations to no avail.

  • I know the key to release from the Host is the Right-Cntrl key.

  • I've read that the Windows (Super) key can be the mod key but this has not seemed to be successful for me. For instance, I've been trying to do Super+Enter to open a terminal.

  • mod is just short for modifier. Ctrl, Alt, Hyper, and Super are all different modifier keys (the Win key is usually treated as Super, and Hyper is unassigned, or vice versa). does your i3 config file (probably /home/username/.config/i3/config) start with "set $mod [something]"? that [something] is the defined mod key. post details of your config file if you still need help. – quixotic Mar 31 '17 at 18:37
  • Hmm, I think the problem is that when I hit my Super key it opens the pop-up menu on my Host machine. I'm new to i3 and I can't figure out how to do anything since everything seems to require the use of the mod key (like opening a terminal)... – BlazePascal Mar 31 '17 at 18:52
  • @BlazePascal Remap mod to alt key in your i3 configuration file. It should be located at $HOME/.config/i3/config. Open it with an editor of your choice and make a necessary edits (i.e. nano $HOME/.config/i3/config). – ddnomad Mar 31 '17 at 18:59
  • @ddnomad Is right click supposed to be disabled at default for i3? I can't seem to figure out how to open anything (terminals, file browers, etc.) except the update manager. In the bottom left window there's some instructions to open a terminal (mod+enter) but that's the issue at hand. In the bottom right I can click on the update manager, sound, network manager. – BlazePascal Mar 31 '17 at 19:04
  • @BlazePascal i3 works only with shortcuts and the majority of them (actually all of them) require a working $mod key. $mod+d launches dmenu which is a minimalist text application launcher. Without working $mod key you won't get far. – ddnomad Mar 31 '17 at 19:07
0

Turns out all I needed to do from the VirtualBox side was go into File->Preferences->Input and then uncheck the "Auto-Capture Keyboard" button.

And then I can do $mod+enter to get the terminal (and all other functionality working.

  • default i3 mapping sets $mod to either win/super or alt key. What do you mean by Windows/Super+$mod+enter? Do you mean just $mod+enter? – ddnomad Mar 31 '17 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.