0

After doing a huge upgrade (over 1.5GB) and then running apt auto-remove this is what I get while trying to update/upgrade.

The command apt list --upgradable shows me there are packaged to be upgraded but running the apt upgrade command does nothing.

root@kali:~# apt list --upgradable 
Listing... Done
erlang-asn1/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-base/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-crypto/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-eunit/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-inets/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-mnesia/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-os-mon/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-public-key/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-runtime-tools/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-snmp/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-ssl/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-syntax-tools/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-tools/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
erlang-xmerl/kali-rolling 1:19.2.1+dfsg-1 amd64 [upgradable from: 1:18.3.4.4+dfsg-1]
gir1.2-mutter-3.0/kali-rolling 3.22.3-2 amd64 [upgradable from: 3.20.3-2]
gnome-core/kali-rolling 1:3.22+1 amd64 [upgradable from: 1:3.20+1]
gnome-shell/kali-rolling 3.22.3-2 amd64 [upgradable from: 3.20.3-1+b1]
gnome-shell-common/kali-rolling 3.22.3-2 all [upgradable from: 3.20.3-1]
gnome-shell-extension-workspacestodock/kali-rolling 40-0kali1 all [upgradable from: 36-0kali1]
gnome-shell-extensions/kali-rolling 3.22.2-1kali1 all [upgradable from: 3.20.1-1kali1]
imagemagick/kali-rolling 8:6.9.7.4+dfsg-2 amd64 [upgradable from: 8:6.8.9.9-7.2]
imagemagick-6.q16/kali-rolling 8:6.9.7.4+dfsg-2 amd64 [upgradable from: 8:6.8.9.9-7.2]
imagemagick-common/kali-rolling 8:6.9.7.4+dfsg-2 all [upgradable from: 8:6.8.9.9-7.2]
kali-linux/kali-rolling 2017.1.4 amd64 [upgradable from: 2016.2.12]
libgnome-desktop-3-12/kali-rolling 3.22.2-1 amd64 [upgradable from: 3.21.90-3]
mailutils/kali-rolling 1:3.1.1-1 amd64 [upgradable from: 1:2.99.99-1.1]
mailutils-common/kali-rolling 1:3.1.1-1 all [upgradable from: 1:2.99.99-1.1]
mutter/kali-rolling 3.22.3-2 amd64 [upgradable from: 3.20.3-2]
mutter-common/kali-rolling 3.22.3-2 all [upgradable from: 3.20.3-2]

root@kali:~# apt upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  erlang-asn1 erlang-base erlang-crypto erlang-eunit erlang-inets erlang-mnesia erlang-os-mon erlang-public-key erlang-runtime-tools erlang-snmp erlang-ssl erlang-syntax-tools erlang-tools
  erlang-xmerl gir1.2-mutter-3.0 gnome-core gnome-shell gnome-shell-common gnome-shell-extension-workspacestodock gnome-shell-extensions imagemagick imagemagick-6.q16 imagemagick-common
  kali-linux libgnome-desktop-3-12 mailutils mailutils-common mutter mutter-common
0 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.

Any suggestion?

1 Answer 1

1

Please use

sudo apt full-upgrade

or sudo apt-get dist-upgrade

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .