4

I am using i3wm (specifically i3-gaps) along with albert launcher. I'm observing some weird behavior where there is a large black box behind albert when it is called.

See: enter image description here

albert should just consist of the rounded rectangular shaped field in the middle of that black box - the black box shouldn't be there.

I haven't seen anyone else reporting this issue in the albert repo, so I imagine this is a configuration issue on my part. I've tried floating other qt applications and don't see this, though. I don't necessarily know if albert is considered a floating window - it's not clear to me how i3 sees it to be honest.

Not sure if useful or relevant, but here's the output from xprop for the albert window:

_NET_WM_DESKTOP(CARDINAL) = 2
_NET_WM_STATE(ATOM) = _NET_WM_STATE_ABOVE, _NET_WM_STATE_STAYS_ON_TOP
WM_STATE(WM_STATE):
        window state: Normal
        icon window: 0x0
I3_FLOATING_WINDOW(CARDINAL) = 1
_NET_WM_USER_TIME(CARDINAL) = 3249943
WM_TRANSIENT_FOR(WINDOW): window id # 0x1200007
_NET_WM_ICON_NAME(UTF8_STRING) = 
_NET_WM_ICON(CARDINAL) =    Icon (16 x 16):

XdndAware(ATOM) = BITMAP
WM_NAME(STRING) = "albert"
_NET_WM_NAME(UTF8_STRING) = "albert — Albert"
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x3, 0x24, 0x0, 0x0, 0x0
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_UTILITY, _KDE_NET_WM_WINDOW_TYPE_OVERRIDE, _NET_WM_WINDOW_TYPE_NORMAL
_XEMBED_INFO(_XEMBED_INFO) = 0x0, 0x1
WM_CLIENT_LEADER(WINDOW): window id # 0x1200007
WM_HINTS(WM_HINTS):
        Client accepts input or input focus: True
        Initial state is Normal State.
_NET_WM_PID(CARDINAL) = 627
_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 18874374
WM_CLASS(STRING) = "albert", "albert"
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
WM_NORMAL_HINTS(WM_SIZE_HINTS):
        user specified location: 608, 347
        user specified size: 704 by 119
        program specified minimum size: 704 by 119
        program specified maximum size: 704 by 119
        window gravity: Static

Edit 1

So I was looking through the albert settings panel and noticed a checkbox for 'Display shadow`. Unchecking this significantly reduces the size of the black box, although if you look closely at the corners of the albert field in the picture below you can see that it's still there around where the corners have been rounded.

enter image description here

  • are you running a compositor (compton, xcompmgr, etc)? how are you activating albert in your i3 config? – quixotic Mar 31 '17 at 4:18
  • No compistor. albert is started in the background in xinitrc with just albert & and then is bound to $mod+d in i3 with bindsym $mod+d exec --no-startup-id albert toggle – user3014097 Mar 31 '17 at 12:01
3

As @quixotic alluded to in a comment, you need a compositor running for the transparency to work; otherwise it's displayed as (100% opaque) black.

Install compton, (or compton-git from AUR) and then make sure it's running by adding exec --no-startup-id compton to your i3/config, or .xinitrc as you prefer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.