2

I've been conducting some tests with my OpenVPN which apparently resulted in the exhaustion of my ifconfig pool. Now when I try to connect to the server, it logs:

Thu Mar 30 13:46:11 2017 client/<ip>:<port> MULTI: no free --ifconfig-pool addresses are available
Thu Mar 30 13:46:11 2017 client/<ip>:<port> MULTI: no dynamic or static remote --ifconfig address is available for client/<ip>:<port>

How do I flush/release IPs from the pool?

On a Debian stretch with OpenVPN 2.4.0, OpenSSL 1.0.2k

0

A simple restart of OpenVPN should do this unless you have set something to make it track IPs over restarts.

/etc/init.d/openvpn restart

  • 1
    Although the option is valid, I doubt that OP would have wasted time asking about it if that was a suitable solution. – Julie Pelletier Jun 28 '17 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.