1

I have Solaris 8 OS installed in French.

Is it possible to switch from French to English without reinstalling the OS ? If yes how ?

When locale -a i have this :

POSIX
common
en_US.UTF-8
C
iso_8859_1
en_CA
en_CA.ISO8859-1
en_US
en_US.ISO8859-1
en_US.ISO8859-15
en_US.ISO8859-15@euro
fr_CA
fr_CA.ISO8859-1
iso_8859_15
th
th_TH
th_TH.TIS620

Even when I try to edit /etc/default/init with :

LANG=en_US.ISO8859-15
LC_COLLATE=en_US.ISO8859-15
LC_CTYPE=en_US.ISO8859-15
LC_MESSAGES=en_US.ISO8859-15
LC_MONETARY=en_US.ISO8859-15
LC_NUMERIC=en_US.ISO8859-15
LC_TIME=en_US.ISO8859-15
LC_ALL=en_US.ISO8859-15

and reboot : nothing happens.

To verify the result i always use date and when i reboot : i also have the date in french.

P.S : I have to do this configuration in a computer which isn't here in my office, so i have to this manipulation in a an another computer here in my office and if it works, i'll do it to the other computer.

So the computer here is configured in English and i have to switch it to French. Here is the content of my ~./dt :

C                     errorlog              sessionlogs
Desktop               errorlog.old          sessions
Trash                 errorlog.older        simulateur.dtwmrc
appconfig             help                  startlog
appmanager            icons                 startlog.old
asr.dtwmrc            outils.dtwmrc         startlog.older
bin                   palettes              tmp
bookmarks             sdtfonts              types
dtwmrc                sdtpcaction.conf      wsmenu
en_US.ISO8859-15      sdtpcaction.conf.bak

Thanks

  • export LANG=C ? – Archemar Mar 29 '17 at 12:23
  • @Archemar thanks for the reply but sorry i didn't understand the answer. I have to do as a root : export LANG=C and that's all ? – Hohenheim Mar 29 '17 at 12:29
  • Please elaborate. "Nothing happens" isn't factual. How are you connecting to that Solaris 8 machine? How are you checking the language setting? What is appearing in French you would like to see in English? What did you change in /etc/default/init? – jlliagre Apr 5 '17 at 20:26
  • @jlliagre i edit my question – Hohenheim Apr 6 '17 at 7:25
  • How do you connect to the Solaris 8 machine? Through the text console? telnet/ssh? a graphic environment? Under what account? What shell are you using? – jlliagre Apr 6 '17 at 23:45
1

To switch to the US locale, open with an editor the file named .dtprofile present in your home directory and add this line at the end:

export LC_ALL=en_US.ISO8859-15

or better:

export LC_ALL=en_US.UTF-8

The desktop, shell and all applications should be displayed in English after the next login.

3

lang setting is done by LANG var.

to change for current session just enter

LANG=C
export LANG

for instance (didn't have french installed, so I use portugese)

-bash-3.2$ LANG=pt
-bash-3.2$ date
quarta-feira, 29 de março de 2017 12H39m06s UTC
-bash-3.2$ LANG=C
-bash-3.2$ date
Wed Mar 29 12:39:36 UTC 2017
-bash-3.2$
  • to change only for root, edit .bashrc for root, reconnect.
  • to change for all users, edit /etc/login (or /etc/profile )
  • to change at system level try editing /etc/defaults/init, and reboot.

  • by edit, I mean add the two lines in the file.

  • Thanks for the answer, i don't have /etc/login but the real need is to change it at system level so thank you for the answer i'll try it – Hohenheim Mar 29 '17 at 12:53
  • 1
    it could be /etc/profile or /etc/Profile I edited my answer. – Archemar Mar 29 '17 at 13:00
  • And if you don't have the locale you want, you should just be able to install the package vs reinstalling. – sleepyweasel Mar 29 '17 at 16:56
  • Hi, after trying to edit /etc/default/init and reboot : nothing happens. I want to change the LANG from Fr to en_US forever and don't do it every time when i reboot – Hohenheim Mar 31 '17 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.