2

I am trying to enable TLS 1.1 on my xampp apache server, but it seems like the version of OpenSSL is too old for that. (Error: SSLProtocol: Illegal protocol 'TLSv1.1')

Can anyone help me how I can upgrade OpenSSL? or something easier approach? I need to keep PHP version as 5.3.1.

My configuration is Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1.

Thank you so much!

  • Please clarify what operating system you are using, and what distribution of that OS if applicable. – Tim Kennedy Mar 28 '17 at 14:09
  • I'm not sure if that matters. As I mentioned it is xampp. (if it really matters, it is sitting Windows 7.) – redpotato Mar 28 '17 at 14:22
  • Ahhh, sorry. My ignorance is flaring. Just download a newer xampp package. apachefriends.org/download.html – Tim Kennedy Mar 28 '17 at 14:25
  • The newest xampp package does not have php 5.3.1 version that I need to keep. – redpotato Mar 28 '17 at 15:45
  • You definitely need OpenSSL 1.0.1 or higher, and (acccording to the changelog) httpd+mod_ssl 2.2.23 or higher (including 2.4.anything). Good luck. You might be better off just putting a separate TLS terminator (like nginx, haproxy, or a second/newer httpd) in front of your server. – dave_thompson_085 Mar 28 '17 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.