1

I ave a computer with CentOS 7 installed that boots up using EFI and grub2 (I'm not exactly sure what the difference between UEFI and EFI is). If it makes a difference the partition table is GPT.

The machine boots properly and works fine. However, on startup the grub menu doesn't display correctly. I can't see any of the options and the count down timer "Selected option will boot in 5 4 3" or whatever it says is wrapped (so the start of the sentence is on the right and the end wraps around to the left).

The grub config selects "console" as the terminal output method. I'm not really sure what I'm meant to try changing in order to fix this? How do I go about solving it?

p.s. I haven't made any changes to the default CentOS set up with regards to booting, but there were some options to choose (e.g. I think they allow pure UEFI boot without grub).

5
  • UEFI is successor to EFI as Akito correctly noted; GPT is "related" in a sense that MSFT chose to couple UEFI/GPT, BIOS/MBR for some reason (I can understand a part of it but don't know for sure) so many firmware manufacturers will assume that's the only combos they have to test. Mar 28, 2017 at 8:05
  • Regarding GRUB, what exactly do you see instead of its menu? "console" means textmode console, not a graphical menu; looks like this doesn't work with UEFI GOP correctly in your case, maybe switching to e.g. "gfxboot" with some GRUB_GFXMODE='800x600' nearby and a grub-mkconfig as GRUB2 expects would help. If CentOS isn't a given, you might also try e.g. Debian, openSUSE or, well, ALT (I've implemented UEFI support there :). Mar 28, 2017 at 8:10
  • For general (U)EFI introduction, and a pretty good and readable one, I'd warmly recommend Rod's books on this topic, helped me a lot back then. Mar 28, 2017 at 8:11
  • @MichaelShigorin: CentOS is a given. I have a blank screen except for the wrongly aligned display counting down when my "selection" will be chosen.
    – dave
    Mar 29, 2017 at 3:59
  • try switching GRUB to gfxboot then. Mar 30, 2017 at 9:06

1 Answer 1

1

As a general thumb rule: do not use (U)EFI if you don't know what you're doing.

Introduction Many new mainboards start using UEFI as a default way for the BIOS to boot systems etc. And that's fine for a generic user, who has Windows 10 pre-installed on his Alienware machine. But if the user starts customizing his machine especially regarding the addition of other OSes even more so with Unix based operating systems then stuff gets tricky due to the slow overall standardization of Unified Extensible Firmware Interface.

UEFI vs. EFI First of all, there is no important difference between UEFI and EFI except that UEFI is basically the successor to EFI. Some people could probably call it EFI2.0. UEFI has more functions, but is limited to booting only compatible systems with compatible setups whereas for example the customized EFI made by Apple Inc. supports more of these. But that's not really important in your case.

Explanation for the cause of your problem UEFI is a great thing, that's why I use it myself. It has many good traits and is definitely superior to the Legacy MBR system. Sadly many system nowadays, especially those which don't get fed by capitalistic money sucking, like for example open source OSes, still rely mostly on being used on the old Legacy MBR system. More and more of these distributions, especially the more known ones like Ubuntu for example, become compatible with UEFI but they aren't exactly perfectly prepared for it. Sometimes installation doesn't go smoothly or doesn't work at all. And sometimes people don't exactly know what the differences between UEFI and BIOS/MBR based installations are, so something gets wrongly chosen/configured and then the boot doesn't work properly as in your case.

Summary of what you have to do What usually counts is the general rule of thumb above in this answer. But since you say that your HDD is GPT formatted and your BIOS obviously supports (U)EFI then the only other thing that you should make sure is that you install your OS in (U)EFI mode. Get the newest Rufus for Windows, plug in an empty USB flash drive, select it in Rufus, select Partition as GPT for UEFI (which is the third formatting option). Make sure the USB flash drive is formatted in FAT32. Now choose the CentOS.iso, click start. After it finishes, restart your computer and select ((U)EFI) CentOS Flash Drive in your BIOS. You literally have to select the (U)EFI option, so it gets installed in this mode. Else your problem will probably persist. Then proceed as usual with your installation. If you selected everything right, you can even check if the system selected or even made an EFI partition, which would definitely mean all goes well.

2
  • CentOS is installed in UEFI mode. I have an EFI partition that is used for booting. It works. Only grub has display problems and I'm not sure why (it might not even be UEFI related!).
    – dave
    Mar 29, 2017 at 4:05
  • Did you try to purge and re-install GRUB2? If you want to try it the easy way, you can boot into boot-repair disk. It will basically reset your GRUB2. Maybe it helps?
    – Akito
    Mar 29, 2017 at 4:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .