I was just going along my merry way, browsing the interblag, when all of a sudden I realized, I need to update my OS. So, I go and I open the apt update gui thing, I click upgrade, and I go from 17.1 to 17.2, then 17.2 to 17.3. This is my first mistake. I don't restart before going straight into apt install mintupgrade. I follow the instructions from the mint website, I run mintupgrade check after backing up, and I copy paste the list of packages to a text file. I then run apt remove <giant list of files from text file>. Now things go from bad to worse. I try to repeat and run mintupgrade check. It can't find the command mintupgrade. I run apt install mintupgrade again. Can't find package. Turns out, all the internet things are broken, wired and wireless, and all ifconfig shows is localhost. I try and restart, and now I'm stuck on the loading screen for Ubuntu (?) 17.1, and I have no internet and no more upgrade utility. How may I save myself without a full reinstall, and also how did this happen?

In summary, here are my steps:

  1. apt install mintupgrade
  2. mintupgrade check
  3. Copy list of packages which are blocking the update to text file
  4. apt remove <list of packages from text file>
  5. Restart
  6. Panic!

My best guess of the steps to solve would be:

  1. Figure out how to get ethernet working again
  2. Reinstall mintupgrade
  3. Try again!
  • 1
    Is it really worth it not to fully reinstall and search a long time for an overcomplicated and time-consuming alternative solution? Because it would really make sense in your case...
    – Akito
    Mar 27, 2017 at 1:44
  • 1
    @Akito It probably is, but troubleshooting is so much more fun. Also, I'm sure this happened to someone else who didn't back up, and this would be useful to them. I feel like it's better I ask it then them, because they probably don't do grammar and don't know their way around the command line. Mar 27, 2017 at 1:45
  • Are your /home and /usr/local directories on separate partitions:
    – Akito
    Mar 27, 2017 at 1:47
  • @Akito No, everything is on the same partition. I didn't even know that configuration was possible. Mar 27, 2017 at 1:47
  • 1
    Fixing something the hard way even though you don't have to can be a good way to learn useful skills. I work with a sysadmin who has occasionally fixed things the hard way for just this purpose; the skills he's learned make him one of the better sysadmins under pressure that I've ever seen. When the site is down, the owner is calling every half hour, and the backups are no good, the hard way may be all that you have left, but that's a very bad time to try it the hard way for the first time. Mar 27, 2017 at 5:17

1 Answer 1


Make a fresh install of the newest Linux Mint version on your current Mint partition. (Make sure you use the same username as before.) When everything is finished, replace your copy of the /home folder with the one inside the system, for example like this: sudo cp -r /path/to/your/backup /home/yourusername/


If you copied the whole /home directory (from the root directory) you have to copy it to the same directory. But if you backed up only the /yourusername/ (or ~) directory you have to replace the same part. You have to be absolutely sure, about which directory to paste it, or you could cause some serious whoopsies. This way everything will be restored, except you will have to install all your programs again, manually.

If you want some more information about what to backup to save which parts of your configuration, you can have a look at this: What directories do I need to back up?

  • I just copied my home (~) not /home. I'm still hoping for an answer that might have a hypothesis about how to fix it/what went wrong, but if that answer doesn't turn up, I'll accept yours because at that point I'll have to back up. Would you mind adding some info about what isn't backed up by backing up 1 user's home folder? e.g. Everything apt, groups, etc. and what directories would have to be backed up to restore those things? I'm actually going to just edit a link into your answer if you don't mind. Mar 27, 2017 at 2:04
  • It would quite make the scope of the answer explode, if I explained everything that is backed up in the /home folder and what you lose by not having /usr/local/ backed up. Also it entirely depends on your own system. But generally speaking, your home directory usually has all your profiles for applications, personal preferences and of course personal data stored. Whereas /usr/local stores information about your apps and which you have installed etc.
    – Akito
    Mar 27, 2017 at 2:10
  • Yeah, I sorta realized that right after I typed it and I just editing in a link to a very through answer about what is stored where. Mar 27, 2017 at 2:11
  • 1
    The problem with your "fix" hopes is that even if you find this type of solution it just wouldn't make sense to apply it because it most certainly would be extremely time-consuming and could cause more problems, too. So instead you can just use the above described solution because it simply is better. That's it.
    – Akito
    Mar 27, 2017 at 2:12
  • 1
    I fully understand your attitude, but this method is not efficient. However if it raises your amusement levels, then it fullfills other purposes too and not only the educational which aren't too efficiently gained through this type of process. Which makes what you are doing understandable.
    – Akito
    Mar 27, 2017 at 2:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .