I'm using fish, but I've tried doing konsole -e bash as well (it inserts a visible "s") there. It seems pressing certain Ctrl-* key combos inserts a Ctrl-S before actually sending that particular escape sequence in. For instance, Ctrl-L clears the screen and inserts an @s after my prompt, as if I'd typed it in before the Ctrl-L.

I've disabled the "flow control" thing already.

  • What does echo $TERM say? – dirkt Mar 26 '17 at 17:34
  • @dirkt xterm-256color (in fish, bash, and fish on tmux). – Soham Chowdhury Mar 26 '17 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.