9

Does anyone know how I can copy my customizations of XFCE's settings plus its appearance to another machine?

The settings for appearance/design, panels, keyboard shortcuts and geany are not there yet, like at all.

So far I have done:

  • copied ~/.config/{autostart,xfce4,Thunar} (not literally like that)

  • logged out and back in, rebooted

Resources:

Some info, which is true for both machines:

$ pacman -Qi xfwm4 | grep Version
Version                  : 4.12.4-1

$ uname -r
4.10.5-1-ARCH
  • 1
    I would check what files came with with xfce package and look for configs - some of them are probably stored somewhere in /etc – Arkadiusz Drabczyk Mar 26 '17 at 12:13
10

Xfce usually stores its configuration files in ~/.config/xfce4 (as well as ~/.local/share/xfce4 and ~/.config/Thunar). Copying these directories to your laptop should do the job. Keyboard shortcuts are stored in ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml, so they should get copied as well.

It's possible that after you copy the files they are getting overwritten when you log out of the session, thus preventing the new settings from getting enabled. Perhaps you could try copying the aforementioned directories by logging in through a tty?

Note that there's a global set of configuration files in /etc/xdg/xfce4, /etc/xdg/Thunar/, /etc/xdg/menus, etc. (as well as /etc/xdg/xdg-xubuntu if you're using Xubuntu). If you're copying the configuration files between two systems having completely different base installations, you'll have to copy these files as well.

  • Atm I am working through your comment. 1st thing I have no ticed: ~/.local/share/xfce4 does not exist. – henry Apr 14 '17 at 15:38
  • 1
    @henry that's okay. It needn't exist. In fact, it's only created if you change certain setting (e.g., changing the default terminal to a new terminal launching script). – StrangeAttractor Apr 23 '17 at 15:34
  • Although some time has passed and I did worked through StrangeAttractor's solution... I wouldn't recommend doing it (again). Ultimately it resulted in some annoying little "bugs" with FF and in general in window size-related issues AFAIK. Also the sidebars (also "task bars") didn't work properly. However program-specific dotfiles is an entirely different topic and actually what I would advise anyone else to take on. – henry Oct 3 '18 at 16:36
3

In addition to what StrangeAttractor has said (the files being in ~/.config/xfce4, as well as ~/.local/share/xfce4 and ~/.config/Thunar), there's a caveat: some of the files are overwritten by xfce even if you don't select the "Save session" when logging out. Also, some of the files are loaded in Xfconf and they're not refreshed until you restart.

Because of that, please follow the steps:

  • Log out of xfce before copying the files
  • Copy the files from the terminal (CTRL-ALT-F1)
  • Make sure the proper permissions are set on copied files (they should belong to wanted user; if not, do chown -R user:group .config/xfce4)
  • Then restart the computer (do not relogin immediately, but restart)

This should do the trick. (Tested on xfce 4.12, xubuntu 18.04)

  • You actually don't need to restart, killing the xfconfd process owned by the user who's settings you are overwriting has the same effect. +1 for pointing me the right direction though. – Besworks Jan 31 at 22:05
0

Make sure to check permissions on the copied files - i.e. do a

chown -R user:group /home/user/.config/xfce4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.