3

I've got the following network card:

Bus 001 Device 002: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard

It's accessable through ip tool and properly works with dhcpcd (3rd entry in the output below):

$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp5s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether bc:5f:f4:3a:84:84 brd ff:ff:ff:ff:ff:ff
3: wwp0s18f2u1i1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 0c:5b:8f:27:9a:64 brd ff:ff:ff:ff:ff:ff
    inet 192.168.8.100/24 brd 192.168.8.255 scope global wwp0s18f2u1i1
       valid_lft forever preferred_lft forever
    inet6 fe80::48d6:a9ee:6db4:1236/64 scope link
       valid_lft forever preferred_lft forever

But NetworkManager seems to ignore it:

$ nmcli device show
GENERAL.DEVICE:                         enp5s0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         BC:5F:F4:3A:84:84
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
WIRED-PROPERTIES.CARRIER:               off

GENERAL.DEVICE:                         lo
GENERAL.TYPE:                           loopback
GENERAL.HWADDR:                         00:00:00:00:00:00
GENERAL.MTU:                            65536
GENERAL.STATE:                          10 (unmanaged)
GENERAL.CONNECTION:                     --
GENERAL.CON-PATH:                       --
IP4.ADDRESS[1]:                         127.0.0.1/8
IP4.GATEWAY:                            --
IP6.ADDRESS[1]:                         ::1/128
IP6.GATEWAY:                            --

I can continue using dhcpcd for this connection, but I need to connect to VPN sometimes, and NetworkManager is not allowing me to establish VPN connection unless it's ensured I have LAN connection.

0

Change in /etc/NetworkManager/NetworkManager.conf [ifupdown] managed=false to [ifupdown] managed=true

  • There was an empty config, I've tried to add [ifupdown] managed=true and it has no effect. I've also tried to add only managed=true, and this leads to not starting NM service. – Denis Sheremet Mar 26 '17 at 18:12
  • t was emty? The whole file looks like this. [main] plugins=ifupdown,keyfile [ifupdown] managed=false in original. – user192526 Mar 26 '17 at 18:18
  • I've got this: # Configuration file for NetworkManager. # See "man 5 NetworkManager.conf" for details. – Denis Sheremet Mar 27 '17 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.