1

I'm trying to install Parrot OS 3.5 on a Sony Vaio laptop, as a dual-boot alongside Windows 10. I have no trouble installing from my bootable USB, but Grub doesn't seem to be able to load it. I don't want to run it as a Live Disc, and I don't want to run it in VM, I want to be able to boot directly into it for use as a daily driver OS.

4
  • how did you partition the disk? – z atef Mar 26 '17 at 2:56
  • Initially, I reduced the size of the windows partition by half, and left the remaining HD space unformatted. When that didn't work I tried it as NFTS format. NTFS* – pHazeSiren Mar 26 '17 at 3:17
  • You may need to turn off secure boot to get this to work (I had to do this to get LM 18 to play nice with UEFI for dual boot Win 10/LM situation): msdn.microsoft.com/en-us/windows/hardware/commercialize/… – RyanNerd Mar 26 '17 at 4:18
  • I disabled Secure Boot immediately, as secure boot refused to allow me to select either OS – pHazeSiren Mar 26 '17 at 4:22
0

I did a lot of research and testing, what I ended up having to do was use a second bootable USB running Ubuntu, so that I could run rEFInd alongside efibootmgr (the latter is not included in Live versions of Parrot and Debian).

Using rEFInd to force GRUB to be seen by the UEFI and efibootmgr to force UEFI to load rEFInd and Parrot before trying to load Windows, I was able to overcome UEFI's hatred for anything other than Windows.

Side Note: Even after changing UEFI boot order settings this way, it still told me that I was missing a file, \g21dr.mbr

If you come across this error, what I did was I went back and re-wrote the Parrot OS iso to my USB using Rufus, and in a drop down menu, changed the value from "create MBR for BIOS or UEFI" to "create GPT for UEFI" (I don't remember exactly what each option said, but I changed it from the first option to the third.)

My hope was that if I created it without the need for MBR, it would run properly. Having combined all of these methods, I can definitely say I am typing this on Parrot OS 3.5 after having shut down and started up cold several times, and it loading into Parrot immediately.

Problem solved.

4
  • UEFI doesn't love Windows nor does it hate Linux. It is independent. I am having the same version of ParrotOS installed on my machine alongside Windows 10. Those were your problems: 1st is the third option in Rufus. It is mandatory. 2nd is ParrotOS formatting. It is an HYBRIDISO image, or how those things are called, so the storage medium you write this image on needs to be an exact copy of the image or else something (as in your case) will definitely fail. 3rd thing is, once you take care of thing #1 and #2 you have to make sure to boot the Live DVD of ParrotOS in UEFI mode or else – Akito Mar 26 '17 at 13:42
  • it's no wonder the system complains. What happened in your case is what is technically expected. Actually it had an even friendlier outcome for you, because you shouldn't have been able to load the ParrotOS Live DVD initially in the first place. – Akito Mar 26 '17 at 13:43
  • Thanks for your input, it really helped. I specifically mentioned Sony Vaio, as I had no trouble dual-booting on my HP laptop, and doing a search for dual-booting on Sony Vaio specifically showed that this was a huge problem for those devices. – pHazeSiren Mar 26 '17 at 22:14
  • I'm happy I was helpful! – Akito Mar 26 '17 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.