2

I'm using Telegram Desktop on Debian 8.7. It starts automatically even though I've not created any .desktop file under ~/.kde/Autostart. It's quite annoying as I don't want its window to show up maximised but I'd rather start it with the --startintray flag. I've also tried to create the .desktop file under the Autostart folder but that seems to not override this weird behaviour. By opening the running services I can see why this occurs (why telegram opens by itself), I get the following hint when I go over "Telegram" with the cursor:

screenshot

3

I fixed it! KDE was saving the session upon shutdown and restoring it upon startup, thus reopening all programs.

I disabled it under Startup and Workspace > Startup and Shutdown > Desktop Session > On Login > Start with an empty session. (Restore previous session was the default)

  • 1
    It worked for me, although in KDE 5.15 I found that option under Workspace then Statup and Shutdown. – Jamo Jun 12 at 15:12
0

Remove it from ~/.config/autostart/. Or, if it is present in /etc/xdg/autostart, then copy it to ~/.config/autostart/ and edit it as desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.