1

I just installed Linux Deepin. I started the driver installation and selected the "nvida-driver" and "intel-micro-code". When they where finished, I tried to reboot. I first tried the logout feature, then I logged back in and pressed the lock button. Then I was greeted with a black terminal window with a blinking underscore.

I next tried pressing Ctrl+Alt+Del to reboot the computer, and then when it booted again I got greeted with the same blinking underscore. I was thinking that maybe it took some time to boot. I checked back maybe 20 minutes later and the underscore was still there.

How do I get the normal desktop back? I can do Ctrl+Alt+F2 and login with root in text mode.

  • @Fox After Pressing Ctrl + Alt + Del I got a Deepin thing. So i think it rebooted fine! – sladet Mar 25 '17 at 15:44
  • @Fox Does the same As Ctrl + Alt + Del – sladet Mar 25 '17 at 15:59
  • @Fox It say like. That i dont have any screens connected and that The Connection was Refused. – sladet Mar 25 '17 at 16:37
  • Pic of it : drive.google.com/open?id=0B30nfNvLAotxaFJsWkFxVThxWlk – sladet Mar 25 '17 at 16:42
  • Managed To Fix it by useing a script if found that removed my drivers Source : askubuntu.com/questions/41681/… sudo apt-get remove --purge nvidia-* sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv sudo apt-get install nvidia-common sudo apt-get install xserver-xorg-video-nouveau sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core # Had to add : sudo apt install xserver-xorg; My self. Was not in script sudo apt install xserver-xorg sudo dpkg-reconfigure xserver-xorg – sladet Mar 27 '17 at 13:33
0

Once you enter the Grub menu, select (but don't enter) Deepin, then press the letter E on your keyboard. Replace quiet splash with nomodeset.

Also in case you use Deepin 15.4 Beta, there is currently a horrible bug with th updated version of libdtk* packages. Don't upgrade the system, if you are on 15.4 Beta.

  • I Found splash quiet and not quiet splash on the end of a line and replaced that with nomodeset and that just removed the deepin flowing water animation thing. It did not fix it! – sladet Mar 28 '17 at 14:05
  • Then you either removed all graphics drivers an replaced it with nvidia's or you did something additional to let the system stop booting. Because if you put in the nomodeset parameter, the newly installed nvidia driver won't be loaded and everything should work as it did before. – Akito Mar 28 '17 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.