1

Issue:

I am running Raspbian (from February 2017). I have setup the Raspberry Pi to run its bluetooth as A2DP and am streaming audio to it via Amazon Echo Dot (Pandora). It runs great for a good 30 minutes then the audio playback just stops. When I go to check the /var/log/syslogs I find the following:

Errors:

Mar 24 22:12:34 raspberrypi pulseaudio[615]: [pulseaudio] module-loopback.c: Sample rates too different, not adjusting (44100 vs. 85062).
...
...
...
Mar 24 22:19:34 raspberrypi pulseaudio[615]: [pulseaudio] module-loopback.c: Sample rates too different, not adjusting (44100 vs. 462646).

Things I have tried:

I have changed the resample-method from default to trivial and the problem still persists.

I have tried searching online and can't seem to find any similar issues, at least none with any information in what is causing it and none with anything close to resembling a solution.

My Conclusion:

To me it looks as though the sample rate from the Echo Dot seems to continue to grow, and pulseaudio can handle it up until the new rate hits the (base rate * x), in which it becomes "too different" and won't adjust to the new rate.

Questions:

What can be done? Is there something I can disable that will allow for playback? Is there anyway to reset the incoming rate to a more manageable number once it gets too high?

Band-aid Fixes:

I can manually disconnect the Amazon Echo Dot, and reconnect the dot and audio playback will begin again and play normally for another 20-30 minutes until the issue begins again.

Update:

I have tried setting the resampling rate again to trivial this time I receive the following error:

Mar 25 02:11:45 raspberrypi pulseaudio[595]: [bluetooth] module-bluez5-device.c: SBC decoding error (-2)

I am suspecting this is "progress", but what can be about this specific error?

  • 1
    I'ld suspect that after some time the information in the data stream gets erraneous, and some data are interpreted as "sample rate". Especially 462646 is way too high for sample rates... – ridgy Mar 25 '17 at 10:27
  • So Is there any work around? And would this possibly be an issue with the dot or with pulse? @ridgy Edit: my assumption would be this is a pulseaudio thing as when reconnecting fixes the issue. – Brett Reinhard Mar 25 '17 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.