2

Everything seem to work on this command ntpq -pn, it show me:

     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
-184.105.182.7   216.218.254.202  2 u   54   64  377   79.218  -11.053   0.466
+69.195.159.158  208.100.0.228    3 u   65   64  377   36.752   -7.735   0.407
-74.120.81.219   128.138.140.44   2 u   64   64  377   34.972   -1.763  16.977
*45.55.102.31    98.175.203.200   2 u   61   64  377    7.723   -3.781   4.854
+91.189.94.4     193.79.237.14    2 u   60   64  377   79.423   -2.344   0.520

and ntpdate -d 192.168.1.231 show me:

24 Mar 15:40:25 ntpdate[12564]: ntpdate 4.2.8p4@1.3265-o Wed Oct  5 12:34:47 UTC 2016 (1)
Looking for host 192.168.1.231 and service ntp
host found : 192.168.1.231
transmit(192.168.1.231)
transmit(192.168.1.231)
transmit(192.168.1.231)
transmit(192.168.1.231)
transmit(192.168.1.231)
192.168.1.231: Server dropped: no data
server 192.168.1.231, port 123
stratum 0, precision 0, leap 00, trust 000
refid [192.168.1.231], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time:    00000000.00000000  Thu, Feb  7 2036  1:28:16.000
originate timestamp: 00000000.00000000  Thu, Feb  7 2036  1:28:16.000
transmit timestamp:  dc7ff4af.1ec5f659  Fri, Mar 24 2017 15:40:31.120
filter delay:  0.00000  0.00000  0.00000  0.00000 
         0.00000  0.00000  0.00000  0.00000 
filter offset: 0.000000 0.000000 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

24 Mar 15:40:33 ntpdate[12564]: no server suitable for synchronization found

on the last line "no server suitable for synchronization found" how to make it become "found"

Even When I tried to use this command ntdc:

root@Lab-X230:/home/igor# ntpdc
ntpdc> peers
localhost: timed out, nothing received
***Request timed out

root@Lab-X230:/home/igor# sudo vim /etc/ntp.conf

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

# Specify one or more NTP servers.

# Use servers from the NTP Pool Project. Approved by Ubuntu Technical Board
# on 2011-02-08 (LP: #104525). See http://www.pool.ntp.org/join.html for
# more information.
#pool 0.ubuntu.pool.ntp.org iburst
#pool 1.ubuntu.pool.ntp.org iburst
#pool 2.ubuntu.pool.ntp.org iburst
#pool 3.ubuntu.pool.ntp.org iburst

# Use Ubuntu's ntp server as a fallback.
#pool ntp.ubuntu.com
server 0.ubuntu.pool.ntp.org iburst
server 1.ubuntu.pool.ntp.org iburst
server 2.ubuntu.pool.ntp.org iburst
server 3.ubuntu.pool.ntp.org iburst

server ntp.ubuntu.com iburst

# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery limited
"/etc/ntp.conf" 74L, 2669C                                                                                                                            26,1          Top

#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery limited
restrict -6 default kod notrap nomodify nopeer noquery limited

# Local users may interrogate the ntp server more closely.
#restrict default ignore
#restrict 127.0.0.1 mask 255.255.255.255
restrict 127.0.0.1
restrict ::1

# Needed for adding pool entries
restrict source notrap nomodify noquery

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient

#Changes recquired to use pps synchonisation as explained in documentation:
#http://www.ntp.org/ntpfaq/NTP-s-config-adv.htm#AEN3918

#server 127.127.8.1 mode 135 prefer    # Meinberg GPS167 with PPS
#fudge 127.127.8.1 time1 0.0042        # relative to PPS for my hardware

#server 127.127.22.1                   # ATOM(PPS)
#fudge 127.127.22.1 flag3 1            # enable PPS API

The expextation should be followed this link at 5.1.3.3 http://www.ntp.org/ntpfaq/NTP-s-algo.htm#Q-ACCURATE-CLOCK, such as:

 ntpdc> loopinfo

offset:               -0.000102 s
frequency:            16.795 ppm
poll adjust:          6
watchdog timer:       63 s
5

Basically, it's because ntpq uses "mode 6" queries and ntpdc uses "mode 7" queries (both of those names are from a field in the NTP protocol). Mode 7 queries (and ntpdc) are deprecated and disabled by default.

Try the ntpq commands rv, kerninfo, and sysinfo to give all that info (and far more). If you must use ntpdc, then you can re-enable mode 7 (instructions in the above link, but beware it's been the source of security problems in the past).

As for ntpdate -d 192.168.1.231, presuming that's the IP address of this NTP server, I'd suggest checking firewall rules. You don't appear to have noserve or ignore in your config. Note also that ntpdate is mostly deprecated, and ntpd has a -q option instead.

  • I am sorry for not understanding the note you mentioned "You don't appear to have noserve or ignore in your config", I disable firewall since I worked on the ntp (sudo ufw disable") – Nate Duong Mar 26 '17 at 22:09
  • @NateDuong noserve and ignore are the options (on a restrict line) that would configure ntpd not to serve time to a host. I don't see them in the config, so ntpd should serve time. – derobert Mar 27 '17 at 23:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.